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Trend Micro™ ServerProtect™ 5.8 Patch 3 Getting Started Guide 
The Getting Started Guide for Trend Micro™ ServerProtect™ is intended to introduce 
the main features of the software and installation instructions for your production 
environment. You should read through it prior to installing or using the software.

Detailed information about how to use specific features within the software are available 
in the online help file and online knowledge base at the Trend Micro Web site.

At Trend Micro, we are always seeking to improve our documentation. If you have 
questions, comments, or suggestions about this or any Trend Micro document, please 
contact us at docs@trendmicro.com. Your feedback is always welcome. Please 
evaluate this documentation on the following site: 
www.trendmicro.com/download/documentation/rating.asp
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Chapter 1

Getting Started with Trend Micro™ 
ServerProtect™

ServerProtect is the latest generation of award-winning software for protecting file 
servers on corporate networks. It is designed specifically to protect the entire network 
from viruses of any kind by adopting advanced virus-catching technology to ensure that 
your network stays virus-free. ServerProtect detects new file infections, identifies viruses 
in existing files, and detects activity indicating an “unknown” virus may have entered the 
network environment on either the server or workstation.

ServerProtect enables network administrators to manage multiple Microsoft Windows 
and Novell NetWare network servers from a single portable management console. The 
console enables administrators to configure servers in the same domain simultaneously 
and to generate integrated virus incident reports from all of them.

By giving administrators a means to configure, monitor, and maintain antivirus efforts 
through the ServerProtect Management Console, ServerProtect improves and simplifies 
the implementation of corporate virus policy. This results in lower virus protection costs
1-1
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The topics included in this chapter are: 

• What’s New in SeverProtect 5.8? on page 1-6

• How Does ServerProtect Work? on page 1-7

• ServerProtect Architecture on page 1-8

• Real-time Scan Versus On-demand Scan (Scan Now) on page 1-12

• Working with Tasks on page 1-13

• When ServerProtect Finds a Virus (Virus Actions) on page 1-13

• Virus Logs on page 1-15

• Deploying Updates on page 1-16

• ServerProtect Virus Detection Technology on page 1-17

• Additional Features on page 1-22

The following specification is provided to specify the operating system support of Trend 
Micro ServerProtect 5.8 for Microsoft Windows and Novell NetWare. 
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The following table specifies ServerProtect 5.8 support of Windows system

TABLE 1-1.   ServerProtect Support for Microsoft Windows Server System

Version Type

Window 2003 Standard Server x86 and x64 with SP1 or SP2

Enterprise Edition x86 and x64 with SP1 or SP2

Standard Edition R2 x86 and x64 with SP2

Enterprise Edition R2 x86 and x64 with SP2

Storage Server x86 and x64 with SP1 or SP2

Datacenter Edition x86 and x64 with SP1 or SP2

Storage Server R2 x86 and x64 with SP2

Datacenter Edition R2 x86 and x64 with SP2

Windows 2008 Standard Edition x86 and x64 or SP2

Enterprise Edition x86 and x64 or SP2

Storage Server x86 and x64 or SP2

Datacenter Edition x86 and x64 or SP2

Standard Edition with Hyper-V, x64 or SP2

Enterprise Edition with Hyper-V, x64 or SP2

Storage Server with Hyper-V, x64 or SP2

Datacenter with Hyper-V, x64 or SP2

Server 2008 R2 Standard Edition

Server 2008 R2 Enterprise Edition

Server 2008 R2 Datacenter Edition
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The table is provided for the convenience of accurately specifying the support for the 
Windows Server platforms that a certain ServerProtect component offers. For example, 
one can use the "32-bit Windows Server 2008 family platforms" to collectively specify 

Windows 2012 Foundation Edition

Essentials Edition

Standard Edition

Datacenter Edition

Storage Server Standard Edition

Storage Server Workgroup Edition

Server 2012 R2 Standard Edition

Server 2012 R2 Foundation Edition

Server 2012 R2 Datacenter Edition

Server 2012 R2 Essentials Edition

Storage Server 2012 R2 Standard

Storage Server 2012 R2 Workgroup

Windows 2016 Standard Edition

Essentials Edition

Datacenter Edition

Storage Server Standard Edition

Storage Server Workgroup Edition

Windows 2019 Standard Edition

Essentials Edition

Datacenter Edition

Storage Server Standard Edition

Storage Server Workgroup Edition

TABLE 1-1.   ServerProtect Support for Microsoft Windows Server System

Version Type
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the x86 edition of the Windows 2008 Standard Server, Enterprise Server, DataCenter 
Server and Web Server. Note that unless otherwise specified, Windows 2008 Standard 
Server, Enterprise Server and DataCenter Server are without Hyper-V.

For Novell NetWare platforms, NetWare 6.5 is supported by the ServerProtect 5.8 
NetWare Normal Server component.

What’s New in SeverProtect 5.8 Patch 3?
• Adding support for Microsoft Windows 2012 and Windows 2012 R2 servers (See 

Recommended System Requirements on page 2-2).

• Supports Trend Micro Management Communication Protocol (MCP).

What’s New in SeverProtect 5.8?
• Support for Microsoft Windows server platforms including Windows 2000, most 

versions in Windows 2003, Windows 2003 R2, Windows 2008 and Windows 2008 
R2 servers.

• VMWare ESX/ESXi server support

• New spyware pattern support to detect virus infections, which also includes new 
features to perform quarantine, delete, and renaming actions for handling infected 
files

• Ability to run the Normal Server under Novell Open Enterprise Server 2

• Upgrade from ServerProtect 5.58 and 5.7 by running either the installation program 
or deployment program

• Enhanced security when communicating between the Information Server and 
Windows Normal Server

• Latest Damage Cleanup Engine and Anti-Rootkit module as a generic cleaning 
feature

• TMI component upgrade to the latest version v1.12
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How Does ServerProtect Work?
ServerProtect monitors all activity in a file server network. Whenever ServerProtect 
detects that a file in its domain is being accessed, it checks the file for infection.

If it finds that the file is infected, it sends notification messages to pre-defined recipients 
and takes action on the virus according to the ServerProtect configuration. The 
ServerProtect activity log records all the activities of the system.

ServerProtect allows you to design personal scanning profiles—saving you from having 
to re-configure frequently needed settings. You can even assign multiple scanning 
options to a profile and use the profile for special circumstances, for example: scanning 
incoming files only.

How Does ServerProtect Manage Servers?
ServerProtect secures your client/server network using a three-tier architecture: the 
Management Console, the Information Server (middleware), and the Normal Server. 
Together, these components create a powerful, centrally managed, cost-effective 
antivirus security system.

The Management Console provides a user-friendly, Windows-based interface for 
configuring system components. Management Console instructions are sent to the 
Information Server, which then passes them on to the Normal Servers.

Communication Methods
The Management Console uses Transmission Control Protocol/Internet Protocol 
(TCP/IP) with a password-protected logon to communicate with the Information 
Server. The Information Server uses a remote Procedure Call (RPC) to connect to 
Windows or the NetWare Normal Servers.
1-6
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ServerProtect Architecture
ServerProtect protects networks through a three-tier architecture: the Management 
Console, the Information Server, and the Normal Server. The following illustrates the 
relationship between these three components:

FIGURE 1-1.   ServerProtect Three-tier Architecture

The Management Console
The ServerProtect Management Console is a portable console which gives network 
administrators centralized control of multiple network servers and domains. The 
console enables you to simultaneously configure Normal Servers in a specified domain 
and generate integrated virus incident reports for them. The Management Console has 
the following parts:

• Main menu

• Side bar (Shortcut bar)

• ServerProtect domain browser tree

• Configuration area

The ServerProtect domain browser tree shows all the ServerProtect Normal Servers in 
the domain, the status information of each server including the version of the virus 
pattern, the version of the scan engine file, type and that of the operating system, data 
flow direction of real-time scanning and others. Note that the administrator can 
configure how all this data is displayed.
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Tip:  You can use the Management Console to remotely install one or more Normal Servers. 
See Installing a Normal Server on page 2-25.

The Information Server
An Information Server is the main communication hub (middleware) between the 
Management Console and the Normal Servers it manages. It simplifies control of 
Normal Servers by allowing administrators to send instructions and receive information 
from remote sites.

WARNING! An Information Server by itself is defenseless unless a Normal Server is 
installed on the same computer.

Information Server Tips
• If you are performing the very first ServerProtect installation on your network, you 

need to set the destination server as an Information Server, and then configure the 
other Normal Servers to this Information Server. 

• An Information Server must have at least one member domain for supporting 
Normal Servers.

• Because an Information Server is simply a delivery system for information, the 
number of Normal Servers it can manage is, theoretically, only limited by the 
available bandwidth. You might, however, choose to moderate the number of 
Normal Servers you assign to an Information Server for ease of management.

• If you have many servers in different locations, set up an Information Server (IS) in 
each location. 

Note: Benchmark testing results have verified that an Information Server can manage up to 
250 Normal Servers. This number serves as a reference only. The Information Server 
can manage more Normal Servers depending on the available bandwidth.
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Note: The Information Server and the Management Console are native 32-bit components 
of ServerProtect. However, on the 64-bit platform, these components of 
ServerProtect will run on Windows On Windows (WOW) 64 mode.

The Normal Server
A Normal Server can be any server on a network where ServerProtect is installed. This 
is the first line of defense in the ServerProtect architecture and where all the action takes 
place. These servers perform the actual antivirus functions of the system, and are 
managed by an Information Server. 

ServerProtect offers several ways for installing Normal Servers:

• Using the setup program. See Installing a Normal Server from the Setup Program on page 
2-26.

• Using the Management Console. See Installing a Normal Server from the Management 
Console on page 2-32.

• Using Microsoft Server Management Server (SMS). See Deploying through Microsoft 
SMS on page 2-34.

• Using silent mode. See Installing ServerProtect in Silent Mode on page 2-43.

Each of the listed installation methods can be tailored to your specific company needs. 
See Installing a Normal Server on page 2-25.

Note: If the operating system is 32-bit, then 32-bit binaries of the Normal Server 
component of ServerProtect will be installed. If the operating system is 64-bit, then 
64-bit binaries of Normal Server component of ServerProtect will be installed.

WARNING! Because it is time-consuming to install servers individually from the setup 
program, Trend Micro recommends that you install your servers from the 
ServerProtect Management Console.
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ServerProtect Domains
ServerProtect domains are virtual groupings of Normal Servers used to simplify their 
identification and management. You can create, rename, or delete domains according to 
the needs of your network.

Normal Servers in a domain can only be assigned to one Information Server. 
Information Servers, on the other hand, can manage several domains.

The most efficient way to manage network protection is to group all servers in relevant 
ServerProtect domains. For example, you can create a ServerProtect domain called "NS" 
to manage Normal Servers more efficiently. See Managing ServerProtect Domains on page 
3-8.

WARNING! The concept of ServerProtect domains are not that of a Microsoft Win-
dows domain; it is simply a logical grouping of Normal Servers running 
ServerProtect.

ServerProtect domains have the following features:

• Domain filter: Network administrators can set up a filter on an Information Server 
to control what can be viewed from the domain browser tree on the Management 
Console.

• Flexible domain management: After logging on to the console, IT professionals 
can add, rename, move or delete domains according to their preference.

Note: The main feature of the Management Console is to centralize the control multiple 
Normal Servers via a number of Information Server. However a Management console 
can only connect to and control one Information Server at any given time. 
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Real-time Scan Versus On-demand Scan (Scan 
Now)

ServerProtect features two powerful scan functions, Real-time Scan and Scan Now.

Real-time Scan runs continuously on a server and provides the maximum level of virus 
protection. All file I/O events on the server are monitored and infected files are 
prevented from being copied to or from the server. See Using Real-Time Scan on page 
3-48.

Scan Now is a manual virus scan (that is, it occurs immediately after being invoked). Use 
Scan Now to check a server that you suspect may have been exposed to a computer 
virus or about which you want immediate information. See Using Scan Now (Manual Scan) 
on page 3-51.

Tip:  To ensure maximum protection, Trend Micro recommends using both Real-time Scan 
and Scan Now.

Real-time Scan and Scan Now benefits include:

• Redundant File Scan: If a file containing a virus is accidentally downloaded or 
copied, Real-time Scan will stop it. Even if for any reason Real-time Scan is disabled, 
Scan Now will still detect it.

• Efficient File Scan: By default, Real-time Scan is configured to scan files. It has the 
advantage of minimizing the impact to system resources. See Scanning Viruses on 
page 3-44.

• Effective and Flexible File Scan: ServerProtect gives IT professionals effective 
and numerous scan configuration options to protect their networks based on their 
individual needs. See Scanning Viruses on page 3-44.
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Working with Tasks
ServerProtect allows IT professionals to create multiple tasks which can be deployed on 
demand or on a scheduled basis.

Use ServerProtect tasks to:

• Deploy updates

• Run Real-time Scan

• Run Scan Now

• Purge, delete, export, or print logs

• Generate virus scan statistics

ServerProtect tasks benefits include:

• Simultaneous multiple function deployment

• Unattended routine antivirus maintenance procedures on your network

• Improved antivirus management efficiency and control over antivirus policy

Tasks are assigned to a "task owner" who is responsible for maintaining the task. See 
Managing Tasks on page 3-27.

After you install ServerProtect on a server, three default tasks already exist: Scan, 
Statistics, and Deploy. These tasks are essential for managing and monitoring antivirus 
activities on your network. You can modify the target servers of these three default tasks, 
as well as their definitions.

When ServerProtect Finds a Virus (Virus 
Actions)

ServerProtect allows you to configure the type of action that the software takes on 
infected files. In addition to the antivirus protection offered by previous versions, a 
Spyware pattern is now available in ServerProtect 5.8, forming a virus category of its 
own. You can choose a specific course of actions to handle certain types of viruses at 
will. The Damage Cleanup Engine is made more powerful by including the feature of 
Generic Clean.
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There are five possible actions that ServerProtect can take on an infected file:

• Bypass/Ignore: For a manual scan, ServerProtect skips the file without taking any 
corrective action. However, detection of the virus is still recorded in the program’s 
log entries. For Real-time Scan, ServerProtect treats the file as "deny-write," 
protecting it from duplication or modification. See Defining Actions Against Viruses on 
page 3-44 for more information.

• Delete: The infected file is deleted.

• Rename: The infected file extension is renamed to .vir. This prevents the file 
from being executed or opened. If a file of that name with the .vir extension 
already exists, the file will be renamed to .v01, .v02, and so on, until .v99.

• Quarantine: The infected file is moved to a folder of your choice. You can also 
change the file extension of the moved file to prevent it from being inadvertently 
opened or executed.

• Clean: Attempt to clean the virus code from the file. Because the cleaning process 
sometimes corrupts the file and makes it unusable, you can back up the file before 
cleaning.

All virus events and associated courses of action are recorded in the log file. For more 
information, refer to the Viewing the infection logs topic in the online help and Defining 
Actions Against Viruses on page 3-44.

Note: If you select Clean as the virus action, you can specify a secondary action if the 
cleaning process is unsuccessful.

Note: On a 64-bit operating system, ServerProtect detects both 32-bit viruses and 64-bit 
viruses.

Note: ServerProtect 5.8 does not support clean action against spyware infected files. When 
using ActiveAction, the actual effect of an action applied to a spyware infected file 
will be equivalent to that of the Bypass action. 
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Virus Logs
The real power of a centralized antivirus system is its ability to record and present 
information regarding the network's antivirus policy from a single console. IT 
professionals can easily access information while they are monitoring their network 
servers.

ServerProtect provides comprehensive information about scanning, file updating, and 
deploying results. Furthermore, ServerProtect saves the information in a log file which 
can be either retrieved or exported. For example, you can analyze the scanning statistics 
for virus scanning on your network. These statistics include information such as what 
the most common viruses are or which users introduced viruses to the network. In 
addition, you can export the log information to a database or spreadsheet application for 
further analysis.

The default size for the log file is 8000 entries, or up to 10-MB. After the log file exceeds 
8000 entries or 10-MB, which ever is smaller in size. ServerProtect automatically 
renames the log file and creates a new log file. 

You can also take action on the infected files directly from the Scan Result window, 
providing you a convenient way to take appropriate actions on a virus infection event. 
For more information about log files, refer to the ServerProtect online help from the 
ServerProtect Management Console. For more information on Virus logs, refer to the 
Viewing log information and Viewing Information Server logs topics in the Online Help.
1-14



Getting Started with Trend Micro™ ServerProtect™
Deploying Updates
Trend Micro update is an upgrade and update deployment module for Trend Micro 
antivirus software. It simplifies the maintenance of Trend Micro software and reduces 
the total cost of your network’s antivirus security. Because of the number of viruses that 
are developed monthly, a successful virus policy depends on the use of virus pattern files 
and scan engine files, that can deal with the latest threats. See Configuring Updates on page 
3-13.

Note: Trend Micro releases new versions of these downloadable update files on a regular 
basis.

ServerProtect update features include:

• Update component selection: Trend Micro provides a rich set of anti virus 
utilities in ServerProtect 5.8 for updating, including newly-added Spyware pattern 
and other virus patterns, Damage Cleanup Engine and a Damage Cleanup 
Template, as well as Anti-rootkit driver.

• Unattended scheduled update: You can create scheduled update tasks to update 
all Normal Servers while you are asleep.

• Flexible file download: You can designate an Information Server to download 
updates from the Trend Micro update site, then have other servers obtain the 
updated files from it. 

• Centralized update deployment: You can deploy updates to servers on your 
network from the Management Console.

• Firewall and proxy server compatibility: ServerProtect works with the majority 
of existing firewalls and proxy servers.

• Update activity logging: ServerProtect records all update activity in a log file for 
future reference.

• Update Roll-back option: If you encounter a problem while deploying an update, 
you can only roll-back the component which is most recently updated. Note that the 
rollback operation can only be carried out on virus patterns and Virus Scan Engine.
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Note: The version 5.8 ServerProtect now supports the update of program files.

Updating ServerProtect is a two-step process: 

1. Download updates from the Trend Micro update server. See Downloading Updates on 
page 3-17.

2. Deploy the downloaded updates to other Normal Servers on the network. See 
Deploying Updates on page 3-23.

This highly efficient approach saves download time and minimizes network bandwidth 
usage.

Tip:  You can automate the deployment of updates for Normal Servers by creating a 
scheduled update task. See Creating Tasks on page 3-28.

ServerProtect Virus Detection Technology
ServerProtect uses advanced virus detection technology. In this section, we feature the 
tools which support this state of the art technology and how IT professionals can 
benefit from it.

Pattern Matching
Using a process called "pattern matching," ServerProtect draws on an extensive database 
of virus patterns to identify known virus signatures. Key areas of suspect files are 
examined for tell-tale strings of virus code and compared against thousands of virus 
signatures that Trend Micro has on record.

For polymorphic or mutation viruses, the ServerProtect scan engine permits suspicious 
files to execute in a protected area within which it is decrypted. ServerProtect then scans 
the entire file, including the freshly decrypted code, and looks for strings of 
mutation-virus code.
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If such a virus is found, ServerProtect performs the action you previously specified to 
handle it. ServerProtect virus actions include clean (autoclean), delete, bypass (ignore), 
quarantine (move), or rename. Virus actions can be customized for both boot viruses 
and file viruses. See Scanning Viruses on page 3-44.

Note: It is important to keep the Spyware pattern and virus pattern files up to date. More 
than a thousand new viruses are created each year. Trend Micro makes it easy to 
update the pattern file by supporting scheduled updates. See Configuring a Scheduled 
Deployment on page 3-24 and Configuring a Scheduled Deployment on page 3-24 for 
more information.

MacroTrap™
ServerProtect includes patented MacroTrap™ technology to guard against macro 
viruses in Microsoft™ Office files and templates. Macro viruses are the fastest 
spreading computer viruses. Because they are harbored in files that are commonly 
passed around by email, these kinds of viruses are easily spread. See Configuring Real-Time 
Scan on page 3-48 for MacroTrap configuration information.

Note: Trend Micro MacroTrap protects network users from receiving and sending macro 
viruses.

How MacroTrap Works
The MacroTrap performs a rule-based examination of all Macro code that is saved in 
association with a document. Macro virus code is typically contained as a part of the 
invisible template (for example., *.dot in Microsoft Word) that travels with the 
document. Trend Micro MacroTrap checks the document for signs of a macro virus by 
seeking out instructions that perform virus-like activity. Examples of virus-like activity 
are copying parts of the template to other templates (replication), or code to execute 
harmful commands (destruction).
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Compressed Files
Compressed file archives (that is, a single file composed of many separate compressed 
files) are the preferred form to distribute files by email and the Internet. Because some 
antivirus software is not able to scan these kinds of files, compressed file archives are 
sometimes used as a way to "smuggle" a virus into a protected network or computer.

The Trend Micro scan engine can scan files inside compressed archives. It can even scan 
compressed files that are composed of other compressed files -- up to a maximum of 
five compression layers. 

The Trend Micro scan engine used in ServerProtect can detect viruses in files 
compressed using the following algorithms:

• PKZIP (.zip) & PKZIP_SFX (.exe) 

• LHA (.lzh) & LHA_SFX (.exe) 

• ARJ (.arj) & ARJ_SFX (.exe) 

• CABINET (.cab) 

• TAR 

• GNU ZIP (.gz) 

• RAR (.rar) 

• PKLITE (.exe or .com) 

• LZEXE (.exe) 

• DIET (.com) 

• UNIX PACKED (.z) 

• UNIX COMPACKED (.z) 

• UNIX LZW (.Z) 

• UUENCODE 

• BINHEX 

• BASE64

Note: The Trend Micro scan engine can currently only clean compressed files using the 
PKZIP algorithm. If a virus is found in an archive using other algorithms, they must 
first be decompressed in a temporary directory, then cleaned.
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For compressed file configuration information, refer to Configuring Real-Time Scan on 
page 3-48, and Configuring Scan Now on page 3-51.

Damage Cleanup Services
Damage Cleanup Services (DCS) detects Trojans, based on their behavior, and restores 
modified system files. DCS also terminates Trojan-related processes, and deletes files 
that the Trojan "drops" in the system.

Note: If a spyware infected file is detected, only bypass can be applied. The file will be 
bypassed without any other treatment. Clean function does not apply to spyware 
infection. 

OLE Layer Scan
Microsoft™ Object Linking and Embedding (OLE) allows embedding Microsoft 
Office™ files within themselves. This means that you could have a Microsoft Word 
document inside an Excel spread sheet, and in turn this Excel spread sheet could be 
embedded in a Microsoft™ PowerPoint presentation.

OLE offers a large number of benefits to developers, at the same time it can lead to 
potential infection. To address this issue, Trend Micro has added a new scan feature 
"OLE layer scan" that complements state-of-the-art ServerProtect virus protection. See 
Scanning Viruses on page 3-44.

Tip:  OLE layer scan offers five layers of protection. Trend Micro recommends a setting of 
two OLE layers for Scan Now and a setting of one for a Real-time Scan. A lower setting 
will improve server performance.

IntelliScan
IntelliScan is a new method of identifying which files to scan that is both more secure, 
and more efficient, than the standard "Scan All files" option.
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For executable files (that is, .zip, .exe), the true file type is determined from the file 
content. In the event that a file is not executable (such as. txt), IntelliScan will use the file 
header to verify the true file type. See Scanning Viruses on page 3-44.

The following are just a couple of the benefits IntelliScan offers to administrators: 

• Performance optimization: Server system resources allotted to scan will be 
minimal, thus using IntelliScan will not interfere with other crucial applications 
running on the server.

• Time saving: Because IntelliScan uses true file type identification, IntelliScan scan 
time is significantly less than that of all files scan (this means that only files with a 
greater risk of being infected are scanned). This time difference is noticeable when 
you use IntelliScan with Scan Now. See Configuring Scan Now on page 3-51.

ActiveAction
ActiveAction is a set of pre-configured scan actions that can be performed on viruses 
and other types of malware. ActiveAction can be configured for both Scan Now and 
Real-time Scan.

When to Select ActiveAction
Trend Micro recommends that you select ActiveAction if you are not familiar with virus 
actions or if you are unsure of which scan action is the most suitable for a certain virus.

Viruses vary significantly from one another; this requires appropriate virus actions for 
each virus type. Customizing scan actions for file viruses requires knowledge of viruses 
and can be a tedious task. For this reason, Trend Micro recommends the use of 
ActiveAction.

Some advantages of using ActiveAction versus customized scan actions are:

• Time saving: You spend no time customizing virus actions.

• Worry-free maintenance: ActiveAction uses Trend Micro recommended scan 
actions so you can concentrate on other tasks and not worry about making mistakes.

• Updateable scan actions: Trend Micro includes new ActiveAction scan actions 
with every new pattern. Viruses constantly change how they attack, thus scan 
actions should be frequently modified to prevent possible infection.
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For ActiveAction configuration information, See Defining Actions Against Viruses on page 
3-44.

Note: When using ActiveAction, the action for spyware virus is bypass/bypass.

Mapped Network Drive Scan
ServerProtect can scan one or several network drive(s); the shared network folders have 
to be mapped first before selecting this feature. This is helpful because Real-time Scan 
scans and protects mapped drives as it does with local drives, therefore reducing the risk 
of infection. See Configuring Real-Time Scan on page 3-48.

Additional Features
To help IT professionals protect their networks with more flexibility, ServerProtect 
includes additional features.

Centralized Management
ServerProtect provides a Windows-based console (the Management Console) to help 
you manage virus protection for multiple servers on your network. The console is 
portable and can be run on any 32-bit or 64-bit Windows server.

Enhanced Network Security on Installation
During Normal or Information Server installation, you must enter the administrator 
user name and password of the selected target servers.
1-21



Trend Micro™ ServerProtect™ 5.8 Patch 3 Getting Started Guide 
Swift Response to Virus Outbreaks
If a virus tries to infect a file in a shared folder on a server under the protection of 
ServerProtect, a message box appears, identifying the computer in the network on which 
the virus originated from. This message box also displays the following information: the 
type of scan, the name of the virus, the name of the infected file, the name or ID of the 
computer involved and the user name. In addition, it also displays the action taken on 
the virus and the source of infection. See Configuring Notification Messages on page 3-38.

Flexible Control over Infected Files
When ServerProtect detects an infected file, you can choose to restore the file after 
cleaning, send suspect or uncleanable files to Trend Micro, delete the backup file made 
before cleaning, or return cleaned files to the user by email.

NetworkTrap Tool
Certain viruses actively seek out shared folders (an example of this type of virus is 
PE.FunLove.4099) to infect as many connected users as possible. The 
NetworkTrap tool lets you share a folder and automatically copies the contents of the 
Bait folder to the newly created shared folder (the Bait’ folder contains files that viruses 
are likely to infect). This shared folder works with the new virus notification to create an 
effective virus trap. For more information on this topic, refer to the NetworkTrap Tool 
section in the online help.

State-of-the-Art Virus Detection Technology
New configurable scanning tools like ActiveAction, IntelliScan, and OLE layer scan 
offer faster and more efficient scanning.

Viewable Scanning Statistics
ServerProtect enables you to efficiently monitor your network antivirus security. It 
displays scanning statistics on your network, including the following, for a given interval: 
total number of viruses found, top ten viruses found, top ten infected users, total 
number of non-cleanable viruses, and more.
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Compatibility
ServerProtect is fully compatible with versions of Microsoft Windows 2003, 2008, 2008 
R2, 2012 and 2012 R2 Server operating systems. The Normal Server component is also 
compatible with Novell NetWare 6.5. It also supports Network File System (NFS) 
drivers, and SOCKS 4 for the Trend Micro update server.

ServerProtect is compatible with 32-bit operating systems and 64-bit operating systems. 
ServerProtect automatically detects 32-bit and 64-bit Windows Servers. If the operating 
system is 32-bit, then 32-bit binaries of the Normal Server component of ServerProtect 
will be installed or uninstalled. If the operating system is 64-bit, then 64-bit binaries of 
the Normal Server component of ServerProtect will be installed or uninstalled.
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Chapter 2

Installing ServerProtect

This chapter includes the following information to successfully install ServerProtect on 
your network(s):

• Recommended System Requirements on page 2-2

• Installation Scenarios on page 2-8

• Installing ServerProtect on page 2-15

• Removing ServerProtect on page 2-45

Note: You must log on with administrator privileges in order to install an Information 
Server.

Note: You cannot install old normal server and register it into ServerProtect 5.8 
Information Server.
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Recommended System Requirements

Normal Server
• CPU: 2.5 GHz Intel™ Pentium™ IV processor or 3.0 GHz EM64T Intel™ 

processor or 2.0 GHz AMD Athlon™ 64-bit processor (or equivalent)

• DRAM:

• Minimum 512-MB, recommended 1-GB

• Windows 2003 Standard Server, x86 and x64, SP1 or SP2

• Windows 2003 Enterprise Server, x86 and x64, SP1 or SP2

• Windows 2003 Standard Server R2, x86 and x64, SP2

• Windows 2003 Enterprise Server R2, x86 and x64, SP2

• Minimum 1-GB, recommended 2-GB

• Windows 2003 Storage Server, x86 and x64, with SP1 or SP2

• Windows 2003 DataCenter Server, x86 and x64, with SP1 or SP2

• Windows 2003 Storage Server R2, x86 and x64, with SP1 or SP2

• Windows 2003 DataCenter Server R2 , x86 and x64, with SP1 or SP2

• Windows 2008 Standard Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 Enterprise Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 Storage Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 DataCenter Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 Standard Server with Hyper-V, x64 or SP2

• Windows 2008 Enterprise Server with Hyper-V, x64 or SP2

• Windows 2008 Storage Server with Hyper-V, x64 or SP2

• Windows 2008 DataCenter Server with Hyper-V, x64 or SP2

• Windows 2008 Standard Server, x86 and x64 or SP2 (server core mode)

• Windows 2008 Enterprise Server, x86 and x64 or SP2 (server core mode)

• Windows 2008 Storage Server, x86 and x64 or SP2 (server core mode)

• Windows 2008 DataCenter Server, x86 and x64 or SP2 (server core mode)

• Windows Server 2008 R2 Standard Edition

• Windows Server 2008 R2 Enterprise Edition
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• Windows Server 2008 R2 Datacenter Edition

• Windows Server 2012 Foundation Edition

• Windows Server 2012 Essentials Edition

• Windows Server 2012 Standard Edition

• Windows Server 2012 Datacenter Edition

• Windows Storage Server 2012 Standard Edition

• Windows Storage Server 2012 Workgroup Edition

• Windows Server 2012 R2 Standard

• Windows Server 2012 R2 Foundation

• Windows Server 2012 R2 Datacenter

• Windows Server 2012 R2 Essentials

• Windows Storage Server 2012 R2 Standard

• Windows Storage Server 2012 R2 Workgroup

• Windows Server 2016 Standard

• Windows Server 2016 Datacenter

• Windows Server 2016 Essentials

• Windows Storage Server 2016 Standard

• Windows Storage Server 2016 Workgroup

• Windows Server 2019 Essentials

• Windows Server 2019 Standard

• Windows Server 2019 Datacenter

• Windows Storage Server 2019 Standard

• Windows Storage Server 2019 Workgroup

Note: See ServerProtect Support for Microsoft Windows Server System on page 1-3 for the 
full name for a specific Windows Server operating system.

• Disk Space: 500 MB, 1 GB recommended.

• 120-MB disk space is required, extra 20-MB if installation of Trend Micro Control 
Manager Agent is needed.

• A CD-ROM drive if the installation is performed locally.
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• Network protocols and services: TCP/IP, Microsoft Network and RPC services 
must be running on Windows Server family operating system.

Information Server
• CPU: 3.0 GHz Intel™ Pentium™ IV processor or 3.0 GHz EM64T Intel™ 

processor or 2.0 GHz AMD Athlon™ 64-bit processor (or equivalent)

• DRAM:

• Minimum 512-MB, recommended 1-GB.

• Windows 2003 Standard Server, x86 and x64, SP1 or SP2

• Windows 2003 Enterprise Server, x86 and x64, SP1 or SP2

• Windows 2003 Standard Server R2, x86 and x64, SP2

• Windows 2003 Enterprise Server R2, x86 and x64, SP2

• Minimum 1-GB, recommended 2-GB.

• Windows 2003 Storage Server, x86 and x64, with SP1 or SP2

• Windows 2003 DataCenter Server, x86 and x64, with SP1 or SP2

• Windows 2003 Storage Server R2, x86 and x64, with SP1 or SP2

• Windows 2003 DataCenter Server R2 , x86 and x64, with SP1 or SP2

• Windows 2008 Standard Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 Enterprise Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 Storage Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 DataCenter Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 Standard Server with Hyper-V, x64 or SP2

• Windows 2008 Enterprise Server with Hyper V, x64 or SP2

• Windows 2008 Storage Server with Hyper-V, x64 or SP2

• Windows 2008 DataCenter Server with Hyper-V, x64 or SP2

• Windows Server 2008 R2 Standard Edition

• Windows Server 2008 R2 Enterprise Edition

• Windows Server 2008 R2 Datacenter Edition

• Windows Server 2012 Foundation Edition

• Windows Server 2012 Essentials Edition
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• Windows Server 2012 Standard Edition

• Windows Server 2012 Datacenter Edition

• Windows Storage Server 2012 Standard Edition

• Windows Storage Server 2012 Workgroup Edition

• Windows Server 2012 R2 Standard

• Windows Server 2012 R2 Foundation

• Windows Server 2012 R2 Datacenter

• Windows Server 2012 R2 Essentials

• Windows Storage Server 2012 R2 Standard

• Windows Storage Server 2012 R2 Workgroup

• Windows Server 2016 Standard

• Windows Server 2016 Datacenter

• Windows Server 2016 Essentials

• Windows Storage Server 2016 Standard

• Windows Storage Server 2016 Workgroup

• Windows Server 2019 Essentials

• Windows Server 2019 Standard

• Windows Server 2019 Datacenter

• Windows Storage Server 2019 Standard

• Windows Storage Server 2019 Workgroup

Note: See ServerProtect Support for Microsoft Windows Server System on page 1-3 for the 
full name for a specific Windows Server operating system.

• Disk Space: 500-MB.

• A CD-ROM drive if the installation is performed locally.

• Network protocols and services: TCP/IP, Microsoft Network and RPC services 
must be running on Windows Server family operating system.

The services listed above must be running on the installed machine. Trend Micro 
recommends an allocated bandwidth usage of at minimum 128 Kilobytes per second to 
optimize deployment of component updates between ServerProtect Information Server 
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and Normal Server. If RPC communication is non-functional, ServerProtect 5.8 will 
automatically switch to another protocol, either named pipe or TCP. To manage 
Windows Server, an Information Server must be installed.

Note: For ActiveUpdate 2.8, additional 500-MB disk space is required if Smart Duplicate is 
needed to be turned on, in which case the cashed pattern number must be set to value 
of 147.

Management Console
• CPU: 2.5 GHz Intel™ Pentium™ IV processor or 3.0 GHz EM64T Intel™ 

processor or 2.0 GHz AMD Athlon™ 64-bit processor (or equivalent)

For Server Environment:

• DRAM:

• Minimum 512-MB, recommended 1-GB.

• Windows 2003 Standard Server, x86 and x64, SP1 or SP2

• Windows 2003 Enterprise Server, x86 and x64, SP1 or SP2

• Windows 2003 Standard Server R2, x86 and x64, SP2

• Windows 2003 Enterprise Server R2, x86 and x64, SP2

• Minimum 1-GB, recommended 2-GB.

• Windows 2003 Storage Server, x86 and x64, with SP1 or SP2

• Windows 2003 DataCenter Server, x86 and x64, with SP1 or SP2

• Windows 2003 Storage Server R2, x86 and x64, with SP1 or SP2

• Windows 2003 DataCenter Server R2 , x86 and x64, with SP1 or SP2

• Windows 2008 Standard Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 Enterprise Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 Storage Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 DataCenter Server, x86 and x64 or SP2 (Without Hyper-V)

• Windows 2008 Standard Server with Hyper-V, x64 or SP2

• Windows 2008 Enterprise Server with Hyper V, x64 or SP2

• Windows 2008 Storage Server with Hyper-V, x64 or SP2
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• Windows 2008 DataCenter Server with Hyper-V, x64 or SP2

• Windows Server 2008 R2 Standard Edition

• Windows Server 2008 R2 Enterprise Edition

• Windows Server 2008 R2 Datacenter Edition

• Windows Server 2012 Foundation Edition

• Windows Server 2012 Essentials Edition

• Windows Server 2012 Standard Edition

• Windows Server 2012 Datacenter Edition

• Windows Storage Server 2012 Standard Edition

• Windows Storage Server 2012 Workgroup Edition

• Windows Server 2012 R2 Standard

• Windows Server 2012 R2 Foundation

• Windows Server 2012 R2 Datacenter

• Windows Server 2012 R2 Essentials

• Windows Storage Server 2012 R2 Standard

• Windows Storage Server 2012 R2 Workgroup

• Windows Server 2016 Standard

• Windows Server 2016 Datacenter

• Windows Server 2016 Essentials

• Windows Storage Server 2016 Standard

• Windows Storage Server 2016 Workgroup

• Windows Server 2019 Essentials

• Windows Server 2019 Standard

• Windows Server 2019 Datacenter

• Windows Storage Server 2019 Standard

• Windows Storage Server 2019 Workgroup

Note: See ServerProtect Support for Microsoft Windows Server System on page 1-3 for a 
specific Windows Server operating system.

• Disk Space: 500-MB.
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For Client Environment:

• DRAM:

• Minimum 512-MB, recommended 1-GB.

• Windows XP Professional 32-bit and 64-bit with SP2 or SP3

• Windows XP Home with SP2 or SP3

• Minimum 1-GB, recommended 2-GB.

• Windows Vista Home/Business/Ultimate 32-bit and 64-bit with SP1 or 
SP2

• Windows 7 Professional/Enterprise/Ultimate 32-bit and 64-bit with SP1   

• Windows 8/Windows 8 Pro/Windows 8 Enterprise 32-bit

• Windows 8/Windows 8 Pro/Windows 8 Enterprise 64-bit

• Windows 10/Windows 10 Pro/Windows 10 Enterprise 32-bit

• Windows 10/Windows 10 Pro/Windows 10 Enterprise 64-bit

Note: See ServerProtect Support for Microsoft Windows Server System on page 1-3 for a 
specific Windows Server operating system.

• Disk Space: 500-MB.

For NetWare Environment:

• Minimum 512-MB, recommended 1-GB.

• Novell NetWare 6.5 SP6, SP7 and SP8

• A monitor with resolution of 1024 x 768 or higher.

• A CD-ROM drive.

• Network protocols and services: TCP/IP, Microsoft Network and RPC services 
must be running on Windows Server family operating system.
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Installation Scenarios
This section will help you select the most appropriate scenario to install ServerProtect 
on your network(s). The following scenarios focus on Local Area Networks (LANs), 
although it is also possible to manage ServerProtect across Wide Area Networks 
(WANs) such as, corporate Intranets, using TCP/IP. See Managing ServerProtect Across a 
Wide Area Network on page 2-14.

Specifying Your Installation Environment
Trend Micro ServerProtect supports Microsoft Windows and Novell NetWare 
platforms. If you are installing ServerProtect on your network for the first time, you 
must set the destination server as an Information Server, then configure the Normal 
Servers to join it. An Information Server must have at least one ServerProtect domain to 
manage its Normal Servers. See ServerProtect Domains on page 1-11.

Note: If you have many servers concentrated in different geographical locations, set up an 
Information Server (IS) in each location. See Information Server Tips on page 1-9.

The following table shows the different installation environments for each ServerProtect 

setup component on Microsoft Windows platforms

TABLE 2-2.   Installation Scenarios on MS Windows

MS Windows Version Information 
Server

Normal 
Server

Management 
Console

Windows Server 2003 family 32-bit Yes Yes Yes

Windows Server 2003 family 64-bit Yes 
(WOW64)

Yes Yes 
(WOW64)

Windows Server 2008 family 32-bit without 
Hyper-V

Yes Yes Yes

Windows Server 2008 family 64-bit with 
Hyper-V

Yes 
(WOW64)

Yes Yes 
(WOW64)
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Windows Server 2008 family 64-bit without 
Hyper-V

Yes 
(WOW64)

Yes Yes 
(WOW64)

Windows Server 2008 family 32-bits server 
core mode

No Yes No

Windows Server 2008 family 64-bits server 
core mode

No Yes No

Windows Server 2008 R2 family Yes 
(WOW64)

Yes Yes 
(WOW64)

Windows Server 2012 family Yes 
(WOW64)

Yes Yes 
(WOW64)

Windows Server 2012 R2 family Yes 
(WOW64)

Yes Yes 
(WOW64)

Windows Server 2016 family Yes 
(WOW64)

Yes Yes 
(WOW64)

Windows Server 2019 family Yes 
(WOW64)

Yes Yes 
(WOW64)

Windows XP Desktop family No No Yes

Windows Vista Desktop family No No Yes

Windows 7 family No No Yes

Windows 8 family No No Yes

TABLE 2-2.   Installation Scenarios on MS Windows

MS Windows Version Information 
Server

Normal 
Server

Management 
Console
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Note: Windows Server 2003 family means Standard version, Enterprise version, Storage 
Server and Datacenter Server.

Windows Server 2008 family means Standard version, Enterprise version, Storage 
Server and Datacenter Server.

Windows Server 2008 R2 family means Standard version, Enterprise version and 
Datacenter Server.

Windows Server 2012 family and Windows 2012 Server R2 family means Standard 
version, Essentials version, Foundation version, Storage and Datacenter server.

Windows Server 2016 family means Standard version, Essentials version, Storage 
Server and Datacenter Server.

Windows Server 2019 family means Standard version, Essentials version, Storage 
Server and Datacenter Server.

Firewall Setting for ServerProtect Components
This page describes the setting of firewall. Please make sure configure your firewall 
correctly to make the communication open. 

Firewall Setting for Machine with Management Console
• Open 1000-1009 port for TCP protocol

1000-1009 is used by Management console to receive the event back message from 
information server. 

Management console will listen at the port 1000 when startup. If the port is occupied by 
other program, management console will find one available port from 1000 – 1009.

Firewall setting for Information Server
• Open 5005 – 5014 ports in TCP protocol. 
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Port 5005 is used to receive the commands from Management Console. Normally, 5005 
must be opened. If it is used by other program, please find one available port from 
5006-5014 and open firewall setting. 

• Open 3000-3009 (UDP) 

Port 3000 is used to receive broadcast message. If port 3000 is occupied by certain 
program, please find one available port from 3000-3009 one by one and open the 
firewall. 

• Open 137-139 and 445 for RPC Over named pipe.

 137 (UDP)

 138 (UDP) 

 139 (TCP)

 445 (TCP)

These ports are opened to enable SPNT to use RPC Over named pipe to communicate. 

• Open 3628(TCP) 

Port 3628 is used to receive event back. 

• Open 1921 for SPX/TCP with Netware

Port 1921 is used to communicate with Netware through the SPX/TCP protocol. 

Firewall setting in the Windows machine with Normal Server
• Open 5168 for listening RPC over TCP/IP from Information Server

Port 5168 is used to receive commands from Information Server. 

• Open 137-139 and 445 for named pipe. 

 137 Protocol is UDP.

 138 Protocol is UDP. 

 139 Protocol is TCP.

 445 Protocol is TCP.

These ports are opened to enable SPNT to use RPC over named pipe to communicate. 

Firewall setting in the netware machine with normal server.

• Open port 9921 (SPX/TCP).
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This port is used to receive commands from Information Server. 

Installation under Microsoft Windows Environment
If you are installing ServerProtect for the first time, and all the servers on your network 
are running a Windows Server, the installation is quite straight forward.

To deploy ServerProtect under the Microsoft Windows environment:

1. Install the Information Server. See Installing an Information Server on page 2-22.

2. Install the Normal Server on the Information Server computer. See Installing a 
Normal Server from the Setup Program on page 2-26.

3. Install the Management Console on the Information Server computer. See Installing 
the Management Console on page 2-20. You can install additional Management 
Consoles on any Windows server or desktop system computer in the network.

Tip:  Only one Management Console can manage an Information Server at any given 
time.

4. Update ServerProtect pattern and scan engine files. See Configuring Updates on page 
3-13.

5. Create additional ServerProtect domains to manage your Normal Servers. See 
Creating ServerProtect Domains on page 3-9.

6. Install the remaining Normal Servers using the Management Console. See Installing 
a Normal Server from the Management Console on page 2-32.

Steps 1, 2 and 3 can be executed simultaneously during the initial Setup.

Installation under NetWare Environment
Even in NetWare environment, the portion of the network in which the Management 
Console and the Information Server play their roles still has to be installed and 
executing on Microsoft Windows platform(s). Only the ServerProtect Normal Server 
component for NetWare (NW) is installed on the NetWare server platforms.
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Installation In An Environment Combined of Microsoft 
Windows and Novell NetWare

ServerProtect can be used to protect a file server network composed of server platforms 
of both Microsoft Windows and Novell NetWare.

FIGURE 2-2.   Microsoft Windows - Novell NetWare Mixed Environment

Managing ServerProtect Across a Wide Area Network
ServerProtect can be managed from multiple locations across a WAN. However, to 
ensure proper network performance, Trend Micro suggests that you install Information 
Servers in the same network domain of a workgroup of the network as the Normal 
Servers they manage.

Because the Management Console uses TCP/IP to communicate with Information 
Servers, it’s easy to manage ServerProtect from any point inside most company 
Intranets.
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Installing ServerProtect
For a server network system on which ServerProtect has never been installed or already 
has been uninstalled, it is recommended that the user choose the complete 
ServerProtect package installation, which includes installing the Management Console, 
Information Server and the Normal Server. The program installed in this way will 
guarantee that the ServerProtect be readily operational, and that the installation 
operation itself be straight forward and smoothly carried out.

This section guides you through the ServerProtect installation process.

Before Installing ServerProtect
As with any server software installation or upgrade, Trend Micro recommends that this 
activity be performed when the impact to users is minimal; that is, outside business 
hours and after a full system backup has been completed. Before carrying out a network 
installation, make sure that the network connections among the related server 
computers are established.

It is also good practice to install the program on a test server first so that installation 
issues, if any, can be identified and handled properly before the installation. Before 
installing ServerProtect, make sure you carefully read the Installation Scenarios section. 
See Installation Scenarios on page 2-8. 

Note: You must be logged on with administrator privileges in order to install ServerProtect.

Installing the Complete ServerProtect Package
To install the complete ServerProtect package, including the Management Console, 
Information Server and the Normal Server, execute the setup program on one or more 
Windows platform computers.
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To install the complete ServerProtect package:

1. Insert the Enterprise CD-ROM and run SETUP.EXE. The ServerProtect Welcome 
screen appears.

FIGURE 2-3.   ServerProtect Welcome sc reen

2. Click Next. The Software License Agreement screen appears. You must agree to 
the license conditions to proceed with Setup.
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FIGURE 2-4.   Software License Agreement screen

3. Click Yes. ServerProtect checks the boot sector of the storage hardware for viruses.

FIGURE 2-5.   Scan Result Information window

4. Click OK to continue. The User Information screen appears. 
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FIGURE 2-6.   ServerProtect User Information screen

5. Provide your user information including the product's serial number.

Even with the serial number field left empty, the ServerProtect will still be installed 
to allow the user enjoy a trial version of the program valid for a 30-day period. If the 
serial number entered is invalid, the installation program appears a message box, 
showing "The serial number is incorrect, please try again".

6. Click Next to continue. The Select Components screen appears.
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FIGURE 2-7.   ServerProtect Select Components screen

7. Select the check boxes for the components you want to install. Make sure the 
selection of the components is adequate for the desired setup. You can choose 
hidden shared storage devices, such as C$ or D$, as destination folders.

The default installation path is:

 <drive>:\Program Files\Trend\SProtect

Note: To protect the Information Server, Trend Micro recommends that you install a 
Normal Server on the computer where the Information Server managing is 
installed.

8. Click Next. If you chose to install either a Normal Server or an Information Server, 
the Input logon Information screen will appear. Under Logon Information, type 
the appropriate data in the Domain name, User name, Password, and Confirm 
Password fields. Click Next to continue.
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FIGURE 2-8.   Input Logon Information screen

9. Follow the instructions given in the following sections to complete the Installation. 

Installing the Management Console
Administrators can remotely manage ServerProtect Normal Servers using the 
Management Console. The Management Console is the ServerProtect component users 
interact with; it can be installed on the same computer along with the Information 
Server and the Normal Server, or on a different computer.

To install the Management Console:

1. Execute the setup program and complete the necessary steps to provide product 
information.

2. At the Select Components screen, select the Install Management Console 
check box. You can change the local installation path by clicking Browse. The 
Management Console must be installed in a Windows Storage Server environment.

Note: Trend Micro does not currently support remote installation of the Management 
Console.
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3. If you want to be the only one to view the ServerProtect program from the 
Windows Start menu, click Personal program folder. Otherwise, click Common 
program folder. Click OK. The Start Copying Files window appears.

4. Click Next to continue with the setup program. Setup starts copying all program 
components and starts all services. After all program components have been 
copied, the ServerProtect Setup screen appears.

FIGURE 2-9.   ServerProtect Setup Complete screen

5. Click Finish. The Select an Information Server window appears.
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FIGURE 2-10.   Select an Information Server screen

6. Select the Information Server that the Management Console will control. Do one 
of the following:

• Select a server from the list.

• Provide the name of the server.

• Provide the IP address of the server.

Note: If an Information Server resides on a different network segment from the one where 
the Management Console is installed, the server will not appear in the list.

7. Click OK to save your changes or click Cancel to close the window without saving.

Installing an Information Server
The Information Server carries out the commands issued by the Management Console 
and manages Normal Servers hosted by its Information Server domain(s).
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To install the Information Server:

1. Execute the setup program and complete the necessary steps to provide product 
information.

2. Select the Install server as a ServerProtect Information Server check box on the 
ServerProtect Select Components screen. See ServerProtect Select Components screen 
on page 2-19

3. Click Browse to specify the path where you want to install the Information Server. 
The ServerProtect Install Path Selection window appears.

FIGURE 2-11.   ServerProtect Install Path Selection screen

4. Double-click the target server and choose the installation path for ServerProtect 
Information Server files. Click New Folder if installation needs to be installed in a 
new folder. Click OK to bring back the ServerProtect Select Components 
screen.See ServerProtect Select Components screen on page 2-19
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5. Click Next. The Input Logon Information screen appears. Under Logon 
Information, type the valid data in the fields of Domain name, User name, 
Password, and Confirm Password and click Next. The ServerProtect Setup 
Information Server screen appears.

FIGURE 2-12.   ServerProtect Setup Information Server screen

6. Provide a password and make the confirmation as requested. This prevents 
unauthorized access to this Information Server from either the Management 
Console or the setup program.

7. Click Next. The Start Copying Files window appears. Verify the information 
listed on the screen.

8. Click Next to continue with the setup program. ServerProtect now starts copying 
all program components and starts all services. After all program components have 
been copied and all services have started successfully, the ServerProtect Setup 
screen appears.
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FIGURE 2-13.   ServerProtect Setup Complete screen 

9. Click Finish. The Install Control Management Agent now screen appears.

FIGURE 2-14.   Control Manager Agent Installation window 

10. Click Yes to the installation of the Control Manager Agent program is needed; 
otherwise, click No to conclude the installation program.

Installing a Normal Server
Use the setup program the first time you install a Normal Server. After that, use the 
Management Console to install additional Normal Servers.
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Installing a Normal Server from the Setup Program
The setup program allows you to install a Normal Server both locally and remotely to 
the server network. The installation procedures for separately Normal Server of 
Microsoft Windows and Novell NetWare will be presented separately. 

Note: Before setting up a NetWare server as a Normal Server, a functioning Information 
Server must be readily available. An Information Server can only be installed onto a 
Windows Server computer, even the Normal Servers it manages are under the 
NetWare environment.

To install a Windows Normal Server from the setup program:

1. Execute the setup program and provide the necessary product information.

2. Select the Install server as a ServerProtect Normal Server check box on the 
Select Components screen. See ServerProtect Select Components screen on page 2-19. 
Click Browse to locate the target server and folder where you want to install a 
Normal Server. The ServerProtect Install Path Selection screen appears.
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FIGURE 2-15.   ServerProtect Install Path Selection screen with 
Windows Server

3. Click the appropriate network to expand the directory tree and select a target server.

4. Click on OK. In the Enter Password screen subsequently appears, type an 
administrator user name and password and click OK. The target server’s local drives 
appear on the tree.

FIGURE 2-16.   ServerProtect Target Server Logon screen 
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5. Select the installation path for the Normal Server. Click New Folder if installation 
needs to be installed in a new folder. Click OK to continue.

6. Click Next in the ServerProtect Select Components screen. The Input Logon 
Information screen appears. 

7. Under Logon Information, type the appropriate data next to the Domain name, 
User name, Password, and Confirm Password fields.

8. Click Next, the ServerProtect Installation Path Selection screen appears.

FIGURE 2-17.   The ServerProtect Installation Path Selection screen

9. To locate the Information Server, do one of the following:

• Type the name or IP address of the Information Server in the text box below 
the tree. Click Find Server.

• Double-click the target server for the Information Server in the browser tree.

10. Click New Domain if a new ServerProtect domain is needed to host the Normal 
Server.
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11. Click Next. The Input ServerProtect Information Server password screen 
appears.

Note: If an Information Server resides on a network different from the one the 
Normal Server does, the server does not show up in the list. To locate the 
Information Server in this case, type the server name or the IP address in the 
Information Server fields.

12. Type the Information Server password and click OK. This password was assigned 
during Information Server installation.

FIGURE 2-18.   Input ServerProtect Information Password window

The Start Copying Files window appears. Verify the information listed on the 
screen.

13. Click Next to continue with the setup program. ServerProtect now starts copying 
all program components and starts all services. After all program components have 
been copied and all services have started successfully, the Setup Complete screen 
appears. See 25

14. Click Finish. An icon ( ) will be added to your Windows taskbar, notifying you 
that the scanner is on.

To install a NetWare Normal Server from the setup program:

1. Execute the setup program and provide the necessary product information.

2. Select the Install server as a ServerProtect Normal Server check box on the 
Select Components screen. See ServerProtect Select Components screen on page 2-19. 
Click Browse to specify the target server and folder where you want to install the 
Normal Server. The ServerProtect Install Path Selection window appears. In this 
case the target server has to be a NetWare server.
2-29



Trend Micro™ ServerProtect™ 5.8 Patch 3 Getting Started Guide 
FIGURE 2-19.   ServerProtect Install Path Selection screen with NetWare 
Server

3. Click the appropriate network to expand the directory tree and select a target server. 
Select the installation path for the NetWare Normal Server. Click New Folder if 
installation needs to be installed in a new folder. Click OK to continue.

4. Click Next in the Select Components screen. The ServerProtect Setup Type 
dialog box appears, presenting the communication protocol options for the 
Information Server.
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FIGURE 2-20.   The NetWare Setup Type screen

5. Set the radio button to select the desired communication protocol and click Next 
to proceed. The SeverProtect - Enter Text dialog box appears.

FIGURE 2-21.   The NetWare Enter Text screen
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6. Provide valid information in the text box field and click Next to proceed. The 
ServerProtect Installation Path Selection dialog box appears again.

FIGURE 2-22.   The ServerProtect Installation Path Selection screen

7. Click on Next to proceed. A dialog box appears requesting password input for the 
Information Server.

8. Type in the valid password. This action dismiss the installation path selection dialog 
box and the NetWare Server is successfully added to the server network.

Installing a Normal Server from the Management Console
It can be assumed at this point that the Information Server on which the Management 
Console is logged on to is already managing at least one Normal Server. This server will 
be used as a source for installing the new Normal Server, so it must be of the same type 
as the one needs to be installed. For example, a Windows Storage server need a server of 
Windows Storage type as its source. The system will select a Normal Server of the same 
type as the default source server if it is the one existing in the domain.
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To install a Microsoft Windows Normal Server from the Management Console:

Note: While installing a Windows Normal Server from the Management Console, ensure 
that the operating system of the source and the target servers are of the same 
platform. For example, if the operating system of the source server is 32-bit, then the 
operating system of the target server should also be 32-bit.

1. From the domain browser tree, select the domain to which you want to add a 
server. Do one of the following:

• Select Domain > Install New SPNT(s) from the main menu.

• Right-click the domain that you selected in the previous step and click Install 
New SPNT(s).

The Select a Source Server window opens.

2. Select an existing Windows Normal Server from the list box, and then click OK. A 
confirmation window appears. Click OK to bring up the Add Server(s) to 
Domain window.

3. Do one of the following to add a server to the domain:

• Select the server name in the left list box

• Type the server name in Server name.

Click Add to enter the server name into the right list box.

4. Repeat step 3 until the right list box displays all the servers that you want to add 
into the new domain. To remove a server previously added, highlight the name in 
the right list box and click Remove. Click Remove All to remove all those servers 
listed in the right list box.

5. Click OK to save the changes or click Cancel to close the window without adding a 
server.

To install a Novell Netware Normal Server from the Management Console:

1. From the domain browser tree, select the domain to which you want to add a 
server. Do one of the following:

• Select Domain > Install New SPNT(s) from the main menu.

• Right-click the domain that you selected in the previous step and click Install 
New SPNT(s).

The Select a Source Server window opens.
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2. Select an existing NetWare Normal Server from the list box, and then click OK. A 
confirmation window appears. Click OK to bring up the Add Server(s) to 
Domain window.

3. Do one of the following to add a server to the domain:

• Select the server name in the left list box

• Type the server name in Server name.

Click Add to enter the server name into the right list box.

4. Repeat step 3 until the right list box displays all the servers that you want to add 
into the new domain. To remove a server previously added, highlight the name in 
the right list box and click Remove. Click Remove All to remove all those servers 
listed in the right list box.

5. Click OK to save the changes or click Cancel to close the window without adding a 
server.

Note: If the operating system of the source and the target servers are of different platforms, 
then a "Failed to complete this operation" message will appear when you click OK. In 
the event log, the message "you cannot install a new ServerProtect from 32-bit source 
server to a 64-bit target server and vice versa" will appear.

Note: Adding and installing a Normal Server are two different types of operation. In the 
former, you are merely transferring an existing Normal Server from one Information 
Server to another. In the latter, you are registering a new Normal Server by remotely 
installing the software.

Deploying through Microsoft SMS
You can install ServerProtect using Microsoft Systems Management Server (SMS) onto a 
Windows Server platform.

Note: You must install the Microsoft SMS software on your Windows Server computer 
before using it to deploy any client software. 
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The deployment procedures listed as follows illustrate how to deploy ServerProtect 
through Microsoft SMS. 

To deploy ServerProtect through Microsoft SMS:

1. Open the Microsoft SMS Administrator.

2. Click Packages on the SMS Administrator’s icon bar.

3. Click Action > New > Package From Definition on the main menu. The 
Welcome to the Create Package from Definition Wizard window appears.

FIGURE 2-23.   Create Package from Definition Wizard window 

4. Click Next. The Package Definition window appears.
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FIGURE 2-24.   File Browser window 

5. Click Browse to locate the package description file (PDF) for installing 
ServerProtect. Select the PDF file and click Open. 

The default directory for ServerProtect software:

<drive>:\program files\Trend\SProtect\SMS\

The description of the PDF file will be displayed as' ServerProtect’ in the Package 
Definition window.
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FIGURE 2-25.   Package Definition window
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6. Click Next, the Source Files window appears.

FIGURE 2-26.   Source Files window

7. Select the Always obtain files from a source directory option and click Next. 
The Source Directory window appears.
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FIGURE 2-27.   Source Directory window 

8. Select the Local drive on site server option. 

9. Click Browse to locate the directory where the package description file (PDF) for 
installing ServerProtect is. Select the directory and click Next. The Completing 
the Create Package from Definition Wizard window appears.
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FIGURE 2-28.   Completing the Create Package from Definition Wizard 
window 

10. Click Finish to create the package.

11. To select the servers/workstations, from where you want to install the software, 
browse to Packages > ServerProtect > Distribution Points in the SMS 
Administrator’s explorer tree.
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FIGURE 2-29.   SMS Administrator window 

12. Right-click Distribution Points and select New > Distribution Points. The 
Copy Package window appears.
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FIGURE 2-30.   Copy Package window 

13. Select the distribution point and click Finish to copy the package to the 
distribution point.

14. To install ServerProtect in multiple servers/workstations, right-click 
Advertisements in the SMS Administrator’s explorer tree.

15. Select New > Advertisement. The Advertisement Properties window appears.
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FIGURE 2-31.   Advertisement Properties window

16. Under General do the following:

a. In the Name text box, type an appropriate advertisement name.

b. In the Package list, select the package you want to deploy.

c. In the Program list, select the program you want to deploy.

d. Click Browse to locate and select the Collection of servers/workstations, 
where you want to deploy the program.

17. Click OK to deploy the program in the servers and workstations collection.

Installing ServerProtect in Silent Mode
Installing ServerProtect in silent mode can be quite useful to remotely install Normal 
Servers under Microsoft Window environment.
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To install ServerProtect in silent mode for Windows Servers:

1. Install an Information Server. See Installing an Information Server on page 2-22.

2. Locate the SMS folder in the default installation path, and share it. Make sure the 
target servers you want to install as Normal Servers can access the folder. If you 
want to perform more than one silent installation, map the SMS folder on the target 
servers.

3. At the target server, open a command prompt, go to the SMS folder or drive that is 
mapped to the folder, and then enter the following command: 

<drive>:\setup -SMS -s -m"SPNT5"

Example:

a. At the target server, map the SMS folder to drive "M".

b. Open a command prompt.

c. Go to drive M: by typing "M:".

d. Type the following:

M:\setup -SMS -s -m"SPNT5"

e. Press Enter.

Silent install will proceed and the target server will be registered with the Information 
Server.

For a silent installation, Normal Servers are installed in the "SMS" domain. There is no 
way to change the domain name during the silent installation. You can, however, rename 
the SMS domain after all the Normal Servers have been installed.

You can also specify a path to which ServerProtect is installed. For example, to install 
ServerProtect to the path "D:\Utility\AntiVirus\SProtect" do the following:

1. Locate the Setup.ini file in the source folder.

2. Add the following lines:

[CommonSection]

ServerTargetUNCPath=D$\Utility\AntiVirus\SProtect

Where:

ServerTargetUNCPath: Sets the location where the Normal Server is installed. 
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To license the installed Normal Server, add the following lines to the Setup.ini file in 
the source folder.

[CommonSection]

ServerTargetSN=XXXX-XXXX-XXXX-XXXX-XXXX

Where:

XXXX-XXXX-XXXX-XXXX-XXXX: Represents the legal serial number.

You may not be able to register a Normal Server under the "SMS" domain due to the 
use of a domain controller on the Information Server. To resolve this issue, configure an 
IP address before using silent install.

To configure an IP address, do the following:

1. Go to the Setup.ini file in the SMS folder.

2. Replace the host name with its IP address next to AgentName then save the file.

Removing ServerProtect
ServerProtect’s three components can be removed either together or separately. 
Individual removal is discussed in the following sections. Note that the UnInstallation 
under Microsoft Window environment differs from that of Novell NetWare.

Removing a Normal Server Under the Windows 
Environment

Under the Microsoft Windows environment, there are two ways to remove a Normal 
Server:

To remove a Normal Server remotely under Windows:

1. Select the Normal Servers intended for removal from the Management Console.

2. From the main menu, navigate from Domain > Uninstall ServerProtect.

To remove a Normal Server locally under Windows:

1. Navigate from Windows Desktop’s Start button > Settings > Control Panel > 
Add/Remove Programs. 

2. Select the Normal Servers intended for removal and click the Remove button.
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Removing a Normal Server Under NetWare Environment
Under the Novell NetWare environment, there are two ways to remove a Normal 
Server:

To remove a Normal Server remotely under NetWare:

• Select the Normal Servers intended for removal from the Management Console. 

• From the main menu, navigate from Domain > Uninstall ServerProtect.

To remove a Normal Server locally under NetWare:

There are two ways to locally uninstall a ServerProtect Normal Server Service from

Novell™ NetWare™ environment:

To uninstall ServerProtect NetWare server(s) from the Management Console:

1. Select the servers from the console.

2. Select Domain > Uninstall ServerProtect from the main menu. All selected 
servers will be remotely uninstalled.

To manually uninstall NetWare Normal Server(s):

1. Press the ESC key on the keyboard then click Yes to unload the ServerProtect 
modules on the ServerProtect monitor screen.

2. Delete the following using the NetWare client for Windows:

SYS:SYSTEM\SPNW.NCF

SYS:LOGIN\SPROTECT

<Volume>: Sprotect directory

3. Delete the following registry contents from the ServerProtect Information Server:

HKEY_LOCAL_MACHINE\SOFTWARE\Trend 
Micro\ServerProtect\CurrentVersion\InformationServer\(the target ServerProtect 
Normal Server)

HKEY_LOCAL_MACHINE\SOFTWARE\Trend 
Micro\ServerProtect\CurrentVersion\NW\(the target ServerProtect 
Normal Server)
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Removing an Information Server
The Information Server Service can only be removed locally.

To remove an Information Server for the Windows Server family platform:

1. Click Start > Control Panel > Add/Remove Programs.

2. Click ServerProtect Information Server, and then click Remove.

Removing the Management Console
The Management Console can only be removed locally.

To remove the ServerProtect Management Console from the Windows Server:

1. Click Start > Control Panel > Add/Remove Programs.

2. Click ServerProtect Management Console, and then click Remove.
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Chapter 3

Managing ServerProtect

This chapter covers the essential tools for managing ServerProtect. Additional 
management tools are explained in the online help of the Management Console.

The topics included in this chapter are:

• Using the Management Console on page 3-2

• Managing ServerProtect Domains on page 3-8

• Managing Information Servers on page 3-11

• Managing Normal Servers on page 3-12

• Configuring Updates on page 3-13

• Deploying Updates on page 3-23

• Managing Tasks on page 3-27

• Configuring Notification Messages on page 3-38

• Scanning Viruses on page 3-44

• Using Real-Time Scan on page 3-48

• Using Scan Now (Manual Scan) on page 3-51

• Scheduled Scanning on page 3-57

• Selecting File Types to Scan on page 3-57

• Registering With Trend Micro Control Manager on page 3-59
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Using the Management Console
ServerProtect allows you to manage virus protection over multiple Microsoft Windows 
and/or Novell NetWare network servers from a single, portable Management Console. 
It is password protected to ensure that only authorized users can change the settings of 
ServerProtect.

Opening the Management Console
The Management Console can run on any 32-bit or 64-bit Windows server or desktop 
computer on the network.

To run the Management Console:

1. Click Start > Trend ServerProtect Management Console. The system prompts 
for the administration password to log on to the selected Information Server. 

FIGURE 3-32.   Trend ServerProtect Management Console Logon 
window

Note: If you are managing more than one Information Server, you will be prompted to 
choose one from a list before proceeding.

2. Provide the valid password which is designated during the course of the 
Information Server installation. Click OK to continue. Note that the password is 
case-sensitive and that only one Information Server can be logged on at any given 
time.

3. If it is the first time for the ServerProtect to run on the system, a message box 
appears, indicating that new updates may be available on the Trend Micro 
AcitveUpdate Server to download and deploy. It is highly recommend that an 
update be performed before using ServerProtect virus scan utilities on the network.
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The Main Window View of the Management Console
The ServerProtect Management Console has an intuitive user interface that provides 
easy access to all the functions you need to configure and manage ServerProtect.

FIGURE 3-33.   Management Console Elements 

The Management Console has the following components:

• The Main Menu is below the program’s title bar. It has six submenus, each provides 
a number of menu items for users to choose.

• The Side Bar is on the left most side of the application window, below the Main 
Menu. The pane contains seven items, each presenting to the user a group of 
options to use.

• The Domain Browser Tree is on the left of the Side Bar and below the Main 
Menu. The tree view presents the way all those ServerProtect are organized, 
including the Information Server and the Domain elements created, together with 
all Normal Servers each domain hosts.
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• The Configuration Area is the pane with light grey background color on the right 
most side of the main Window. It is used to present data information and the 
control UI elements for configuration of the virus scan and log report systems.

Main Menu 
The Main menu at the top of the screen includes six items:

• Information Server: To configure the information about the Information Server. 
For example, to back up or restore information for the Information Server and to 
select or move the Information Server on the network.

• Domain: To change the domain and server organization shown on the domain 
browser tree.

• Configure: To modify the scanning and log file configuration, and to set console 
refresh frequency.

• View: To view ServerProtect log files, scan results, and the Trend Micro Virus 
Encyclopedia.

• Do: 

• To create or modify tasks

• To perform on-demand scans

• To update or roll back various ServerProtect antivirus elements

• To change the IS password

• To find domains or servers

• Help: To access the online help system and the ServerProtect product information.

Side Bar
The side bar is on the left side of the ServerProtect screen and includes seven groups of 
items. It provides shortcuts to different functional areas of the program.

Task Group

New Task: To create a new task

Existing Task List: To view, run, modify, or delete an existing
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Scan Group

Scan Now: To configure a manual virus scan

Scan Result Group

Real-time Scan: To view the result of a real-time scan

Scan Now: To view the result of a manual scan

Task Scan: To view the scanning result performed by a task

Update Group

Update: To download and deploy updates to the Normal Servers 
located on the network

Rollback: To roll back to a previous deployment action performed on 
your network
View Log Group

View Log: To view historical information about antivirus events that 
have occurred on the network
Set Scan Action Group

Real-time Scan: To configure a real-time virus scan on the network

Exclusion List: To define files, directories, or viruses to be ignored by 
the ServerProtect virus scanning engine
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Deny Write List: To prevent certain files or directories from 
modification
Notification Group

Standard Notification: To configure a standard alert when the default 
condition is detected on the server

Outbreak Notification: To configure an outbreak alert when many 
virus events occur over a relatively short period of time

CM Agent Settings: To register, unregister and configure Trend Micro 
Control Manager settings.

Domain Browser Tree
The browser tree displays the network components that your software is protecting and 
includes a root (the ServerProtect product icon), branches (domains), and nodes (the 
ServerProtect Normal Servers). There are four main visible items in the domain browser 
tree:

• Header

• Information Server

• Domain

• Normal Server

Header

The column fields above the domain browser tree display useful information, such as 
the computer’s operating system, virus pattern, scan engine, program versions, real-time 
scan direction, and so on.
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Right-click tree icons in the ServerProtect console to make configuration changes to the 
selected components. The frame that contains the domain browser tree can be resized.

Information Server

An Information Server is the server that handles key information and communication 
for domains. In addition, the Information Server links domains together.

An Information Server

Domain

Domains are groupings of servers on your ServerProtect network. Normal Servers that 
belong to a domain are managed together. ServerProtect domains are different from 
Windows domains.

A ServerProtect domain

A ServerProtect domain that includes an infected Normal Server

Normal Server

The Normal Server can be any server in which ServerProtect is installed on a network. 
In the ServerProtect architecture, a Normal Server is managed by the Information 
Server.

A Normal Server of 32-bit Microsoft Windows Server type.

A Normal Server of 64-bit Microsoft Windows Server type.

A Novell NetWare Normal Server.

An infected Normal Server of 32-bit Microsoft Windows Server type.

An infected Normal Server of 64-bit Microsoft Windows Server type.

An infected Novell NetWare Normal Server.

A Normal Server that has been disconnected or its service has been disabled.

A Normal Server of 32-bit Microsoft Windows Server type in Outbreak. 
Prevention Policy mode.

A Normal Server of 64-bit Microsoft Windows Server type in Outbreak. 
Prevention Policy mode.
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An infected Normal Server of 32-bit Microsoft Windows in Outbreak Prevention 
Policy mode.

An infected Normal Server of 64-bit Microsoft Windows in Outbreak Prevention 
Policy mode.

Configuration Area
On the right side of the ServerProtect screen is the configuration area, where you can 
type configuration data and view information about your corporate network.

FIGURE 3-34.   Configuration Area

Managing ServerProtect Domains
ServerProtect domains are virtual groupings of Normal Servers used to simplify their 
identification and management. You can create, rename, or delete domains according to 
the needs of your network.

Note: If one of the servers in a domain is infected, the domain icon will change and the 
infected server's icon will seem to be on fire. This is to remind you to scan the 
infected server and prevent the virus from spreading throughout your network. To 
eliminate the infection icon(s), you need to purge all log entries under Scan Result in 
the Management Console, or symply open all these log entries.
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Creating ServerProtect Domains
After creating a default domain through the ServerProtect installation program you can 
create a domain from the Management Console.

The maximum length of a domain name is 50 single-byte characters or 25 double-byte 
characters (for Chinese, Japanese, or Korean characters).

To create a ServerProtect domain:

1. Do one of the following:

• Select the Information Server you want to add a domain. Navigate from the 
main menu Domain > Add New Domain.

• Right-click the Information Server icon on the domain browser tree and then 
click Add New Domain.

The Create New Domain window appears.

FIGURE 3-35.   Create New Domain(s) window

2. Type a name in the Domain name field.

3. Identify the servers that you want to add to the domain. Do one of the following:

• Select a server from the list on the left of the screen.

• Type the server name in the Enter server name field.

4. Click Add.

5. Repeat steps 3 and 4 until the list on the right displays all the servers that you want 
to add in the new domain. To remove a server, select it in the list on the right and 
click Remove. Click Remove All to delete all the servers from the list on the right.
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6. Click OK to save your changes or click Cancel to close the window without 
creating a new domain.

Renaming ServerProtect Domains
A domain with your server's name is created as the default domain during ServerProtect 
installation. You can change the name of any existing domain from the Management 
Console.

To rename a ServerProtect domain:

1. Select the domain you want to rename in the domain browser tree.

2. Do one of the following:

• Right-click the selected domain, and then click Rename Domain.

• Select Domain > Rename Domain on the main menu.

• Press the F2 key on the keyboard.

The Rename a Domain window appears.

FIGURE 3-36.   Rename a Domain window

3. Type the new domain name in the To text box and then click OK. Click Cancel to 
close the window without saving.

Deleting ServerProtect Domains
You can delete empty domains (domains that do not include any Normal Servers) you 
no longer need. You cannot delete a domain if it contains any Normal Servers.

To delete a ServerProtect domain:

1. Select the domain that you want to delete on the domain browser tree.

2. Do one of the following:

• Right-click the domain and then click Delete Domain.
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• Click Domain > Delete Domain on the main menu.

• Press the Delete key of the keyboard.

Note: You cannot delete a domain if it contains any Normal Servers.

Moving Normal Servers between Domains
To improve management, sometimes you need to move (remove and add) Normal 
Servers from one domain to another. Select Normal Server(s) under one domain from 
the domain browser tree, then drag and drop between domains.

Alternatively, you can move a Normal Server when you create a ServerProtect domain. 
See Creating ServerProtect Domains on page 3-9.

Managing Information Servers
The Information Server stores and delivers data to and from the Normal Servers. In a 
Windows Server network, the Normal Servers deliver their alert notifications to the 
Windows server. If an Information Server has NetWare Servers under its management, 
it also delivers alert notifications using Microsoft Windows mechanism.

Because an Information Server is simply a delivery system for information, the number 
of servers it can manage is, theoretically, only limited by the available bandwidth.

Tip:  For large networks such as WANs, Trend Micro recommends that you install an 
Information Server in each network segment. This will reduce the impact on traffic.

Selecting Information Servers
Management Consoles can switch between Information Servers. However, only one 
Management Console can log on to an Information Server at any time. If you are not 
able to log on to an Information Server, verify whether another Management Console is 
connected to it.
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To select an Information Server:

1. Click Information Server > Select Information Server on the main menu. The 
Select Information Server window appears.

2. Do one of the following:

• Type the name or IP address of the Information Server. 

• Select the Information Server from the list.

Note that if more than one network interface cards (NIC) are installed on the 
computer, only those Information Servers that connect to the primary NIC are 
visible in the list box window. To refresh the view of servers in the list, click 
Refresh button.

FIGURE 3-37.   Trend ServerProtect Management Console window

3. Click OK to save your changes or click Cancel to close the window without saving.

Managing Normal Servers
In the ServerProtect architecture, the Normal Server is the first line of defense against 
viruses, and is managed by an Information Server. It is at the bottom of the three-tier 
ServerProtect structure. This section explains how to manage Normal Servers.
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Moving a Normal Server between Domains
To move a Normal Server from one ServerProtect domain to another, select a Normal 
Server in the domain browser tree, then drag and drop it between domains.

Moving a Normal Server between Information Servers
ServerProtect allows you to move a Normal Server from one Information Server to 
another. This feature is particularly useful to reduce the load on the Information Server.

To move a Normal Server between Information Servers:

Note: You can not use "Move NS(s) to Another IS" function to move one old normal server 
into ServerProtect 5.8 Information Server.

1. Do one of the following:

• Right-click the Normal Server that you want to move and then click Move 
NS(s) to Another IS.

• Select the Normal Server that you want to move and then click Domain > 
Move NS(s) to Another IS in the main menu.The Select Destination 
Information Server window appears.

• Select the destination Information Server and submit it by clicking on the OK 
button. A dialog box Move NS(s) to Another IS dialog box appears.

• Fill either the User Name/Password fields or that of GUID with proper 
values. Submit the dialog box by clicking on the OK button.

Configuring Updates
Trend Micro update server allows you to update ServerProtect components. The update 
process comprises downloading and deploying the updates.

Update Components
The following are the ServerProtect components that you can update:

• ServerProtect Program: The application program of the ServerProtect can be 
downloaded and deployed. The users now have a new option to upgrade the 
ServerProtect application.
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• Virus pattern file: Trend Micro antivirus scan software uses a detection method 
called pattern matching. Files on a computer are examined and compared to the 
virus pattern file that contains the "electronic fingerprint" of thousands of known 
computer viruses. If a file on your computer matches one in the pattern file, the 
antivirus scan software detects it as being infected.

• Spyware pattern file: The spyware pattern identifies spyware/grayware in files, 
programs and modules in memory, Windows registry and URL shortcuts.

• Scan engine (for 32-bit and 64-bit Windows and NetWare platform): The scan 
engine is the software component that performs the actual virus detect operations.

• Virus Cleanup Engine (for 32-bit and 64-bit Windows): the Engine scans for and 
removes Trojans and Trojan processes. It supports 32-bit and 64-bit platforms.

• Virus Cleanup Template: The Virus Cleanup Template is used by the Virus Cleanup 
Engine to identify Trojan files and processes so the VCE can eliminate them

• Anti-Rootkit Driver (for 32-bit Windows only): Anti-rootkit Driver is a kernel mode 
driver used by the Damage Cleanup Engine that provides functionality to bypass any 
potential redirection by rootkits. 
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How Updates Work
The following figure shows how ServerProtect deals with a typical request to download 
and deploy updates in a ServerProtect network.

FIGURE 3-38.   How Updates Work
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Verifying the Current Version of Files
ServerProtect allows you to check the version of the virus pattern file and scan engine 
currently used by an Information Server.

To verify the current version do one of the following:

• Click Update > Update on the side bar.

• Click Do > Update on the main menu.

FIGURE 3-39.   Trend Micro ServerProtect Update Main Screen

The following version information used by the system are shown at the top of the 
Update screen.

• ServerProtect version.

• Virus Pattern version.

• Spyware Pattern version.

• Virus Scan Engine version (32-bit /64-bit).

• Virus Cleanup Template version.

• Virus Cleanup Engine version (32-bit /64-bit).

• Anti-rootkit Driver version (32-bit only).

• NetWare Virus Scan Engine version, if in use.
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After installing ServerProtect for the first time, the version fields are displayed. Updated 
information will be displayed after you perform a successful update by clicking 
Download Now to download the latest updates from the Trend Micro update server.

Downloading Updates
We recommend that you regularly download updates from Trend Micro update server to 
ensure continued protection. Trend Micro releases new virus pattern files several times 
each week. The scan engine files, on the other hand, are updated less frequently.

After downloading updates from the Trend Micro update server, you can designate a 
network drive to act as a download source (mirror) for other Information Servers on 
your network. This will avoid redundant downloads.

Downloading updates from a network drive is ideal for large networks (such as 
Intranets) with multiple Information Servers. Before attempting to download update 
files from another server, you must make sure the source server has the updated files.

Configuring a Download Source
You can download updated files from Trend Micro update server or copy the files from 
a location on your network. If you want to copy files from a location on your network, 
you must create a download source folder.

To set Trend Micro update server as the download source:

1. Do one of the following:

• Click Update > Update on the side bar.

• Click Do > Update from the main menu.

2. Click Configure in the Download group to open the Download Option window.

3. Click Internet and then type the following URL to download the update files from 
the Trend Micro update server:

http://spnt58-p.activeupdate.trendmicro.com/activeupdate

4. Click OK. The downloaded files will be saved in the following directory of the 
Information Server:

\ProgramFiles\Trend\SProtect\SpntShare
3-17



Trend Micro™ ServerProtect™ 5.8 Patch 3 Getting Started Guide 
To set a local or network drive as the download source:

1. Do one of the following:

• Click Update > Update on the side bar.

• Click Do > Update from the main menu.

2. Under Download, click Configure. The Download Option window appears.

3. Click From a local or network drive.

4. Type the UNC path where the files are being kept to download the update files 
from another server on you network. Use UNC format, rather than mapped drive 
format to identify the source server.

For example:

\\servername\foldername

5. Type the User name and Password to access the source server. The server you are 
updating from must have previously downloaded a copy of the update files.

6. Click OK.

WARNING! In order to download updates from a local or network drive, you must first 
create a download source folder. See the procedure listed below.

To create a download source folder:

1. Execute an update from the Internet by clicking Download Now.

2. Do one of the following:

• Make the SpntShare folder, located under 
\ProgramFiles\Trend\SProtect\ in the designated Information Server, a 
shared folder.

• Create a shared folder on a network server and then copy all the files in the 
SpntShare folder to the mentioned shared folder.

If you do not select the SpntShare folder as your download source, you need to copy 
all the files in the SpntShare folder of the designated Information Server to the 
mentioned shared folder every time you execute an update from the Internet.
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Using Download Now
If updated components are available, you can initiate an immediate download of the 
latest virus pattern files and scan engine files from either the Trend Micro update server 
or another Information Server on your network.

To use Download Now:

1. Do one of the following:

• Click Update > Update on the side bar.

• Click Do > Update on the main menu.

2. Click Download Now on the Update main screen. A progress bar appears to 
show the time remaining until the completion of the update.

Note: Before you use Download Now for the first time, you need to configure the 
download settings. Failure to do so, could prompt an "HTTP generic failure" or 
"HTTP authentication failure" message when you click Download Now. See 
Configuring Download Settings on page 3-20.

ServerProtect logs the event in the Information Server logs.

Configuring a Scheduled Download
You can schedule ServerProtect to download the latest update files from Trend Micro or 
another server on your network.

To configure a scheduled download:

1. Do one of the following:

• Click Update > Update on the side bar.

• Click Do > Update from the main menu.

2. Under Download, click Configure. The Download Option window appears.

3. Click the Schedule Setting tab.
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FIGURE 3-40.   Download Option--Schedule Setting window

4. Under Schedule in the Frequency list, click a download frequency. You can select 
None, Hourly, Daily or Weekly. If you do not want to schedule a download, click 
None. If you click Weekly, in the Day of Week list, click a day.

5. In the Time box, type or select the time when you want to update the components, 
and then click AM or PM.

6. Select the Retry check box to instruct ServerProtect to attempt to reconnect to the 
download server if the initial download operation is unsuccessful. In the Times and 
Delay boxes, type or select the number of times and the delay you want between 
each retry.

7. Click OK. The downloaded files will be saved under the following directory:

\Trend\SProtect\SpntShare

Configuring Download Settings
The following steps describe how to download the update files

To configure the download settings:

1. Do one of the following:

• Click Update > Update on the side bar.
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• Click Do > Update on the main menu.

2. Click Configure on the Update screen to change your download configuration. 
The Download Option window appears.

FIGURE 3-41.   Download Option window 

Configuring the Proxy Server Settings
You can configure ServerProtect to use your proxy server settings while connected to 
the Internet.

To configure a proxy server setting:

1. Choose one of the following:

• Click Update > Update on the side bar.

• Click Do > Update from the main menu.

2. Under Download, click Configure. The Download Option window appears.

3. Click the Proxy Setting tab.
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FIGURE 3-42.   Download Option--Proxy Setting window

4. Select the Connect to the Internet through a proxy server check box.

5. In the Protocol type list, click the protocol used for downloading. The protocols 
supported are: HTTP and SOCKS 4.

6. Under Proxy Setting do the following:

• In the Proxy Server and Port no text boxes, type the name of the proxy server 
and the port number used.

• In the User name and Password text boxes, type the appropriate information 
for the proxy server.

7. Click OK.
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Deploying Updates
When an Information Server deploys updates to Normal Servers, it sends commands to 
each Normal Server, requesting them to obtain a copy of the updates. ServerProtect 
records both the connection and deployment process in a log file. 

Configuring Deploy Now
The Deploy Now function is used to deploy the updates saved in an Information 
Server to other Normal Servers. 

To deploy an update:

1. Do one of the following:

• Click Update > Update on the side bar.

• Click Do > Update from the main menu.

2. Click Deploy Now. A confirmation window appears. Click Yes to proceed with the 
manual update deployment. The Deploy window appears.

FIGURE 3-43.   Deploy window
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A number of check boxes in the Select component group present those 
components readily to be deployed to the Normal Servers. The check boxes of 
Virus pattern, Spyware and Virus cleanup Template are selected at the 
application initiation stage as part of default configuration settings. In Select server 
pane, the version information of each downloaded ServerProtect antivirus elements 
is shown in the tree view UI element. For a 64-bit Window server, the available 
check boxes presented in the Select Component group are the Server protect 
program, the Virus pattern, the Spyware pattern, the Virus Scan Engine, the 
Virus Cleanup Template and the Virus Cleanup Engine. For a 32-bit Windows 
Server, an Anti-rootkit Driver check box, together with the six elements for 64-bit 
Windows described, is also presented.

3. To apply intended antivirus protections, set the check boxes corresponding to these 
components in Select Component Group, then set the check boxes corresponding 
to those Normal Servers need to be deployed in the Select server tree view UI 
element. Click Deploy to deploy the downloaded elements.

Configuring a Scheduled Deployment
After downloading updates on a scheduled basis, configure a scheduled deployment task 
to distribute the most recent updates to the Normal Servers.

ServerProtect creates a deploy task by default. See Default tasks on page 3-28.

For more information on how to configure a scheduled task, refer to Creating Tasks on 
page 3-28.

Tip:  When setting the time for downloading and deploying updates, be sure to set the 
download time before the deployment.

To configure a scheduled deployment:

1. Do one of the following:

• Click Update > Update on the side bar.

• Click Do > Update from the main menu.

2. Click Configure in the Deploy section. The Deploy Option window appears. 
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FIGURE 3-44.   Deploy Options window

3. Do one of the following:

• Click New task, to create a task.

• Click Existing task, to edit a task.

See Creating Tasks on page 3-28 and Modifying an Existing Task on page 3-34 for 
information on how to create or edit a task.

Rolling Back the Previous Deployment Action
ServerProtect can roll back a deployed update action; reverting the system to the 
previous version of the updated file. Only the virus pattern and the virus scan engine 
can be rolled back. This is necessary when there is a software compatibility issue or 
when the update files were corrupted during the original download.

Note: If both the virus pattern and the scan engine files were originally deployed, you must 
roll both of them back.

To roll back the previously deployed update:

1. Do one of the following:

• Click Update > Rollback on the side bar.

• Click Do > Rollback on the main menu.

The Rollback screen appears. 
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FIGURE 3-45.   Roll Back Configuration window

2. Click Rollback. The ServerProtect Rollback window appears.

FIGURE 3-46.   Rollback window 

The screen displays information about the virus pattern file and scan engine that is 
currently being used by ServerProtect. The respective version and build numbers 
are also shown.

3. Select the check boxes of the items you want to roll back, and then click Rollback.
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Note: You can only roll back the components which is most recently updated, The 
components can either be a virus pattern or a scan engine.

Managing Tasks
Tasks allow you to schedule Normal Servers to perform multiple functions 
simultaneously. Using tasks automates routine antivirus maintenance procedures on 
your network and improves the management of your antivirus policy.

You can define a task to run several procedures at one time in the same manner as 
macros automate word processing programs, or scripts automate routine network 
administration tasks.

Tasks are assigned to a "task owner" who is responsible for maintaining the task.

ServerProtect Task Wizard
The ServerProtect Task Wizard provides an intuitive interface for you to easily define a 
task. You can include the following functions in a task:

• Real-time Scan setting: Enables different Real-time Scan options for different 
tasks, for example, scanning incoming files only when the network performance is 
normal

• Scan Now: Checks whether your server is virus-free

• Purge logs: Defines which types of logs to purge from the database. You can 
enable the automatic purging of virus logs that are older than a preset age.

• Export logs: Exports logs as CSV files for use in other applications

• Print logs: Chooses a network printer to print logs that meet a certain criteria

• Run statistics: Compiles and displays statistics about virus scanning on your server

• Deploy: Defines when to distribute the updates of virus pattern and scan engine 
components to other ServerProtect servers
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FIGURE 3-47.   Task Wizard window 

Default tasks
Default tasks are created by ServerProtect with every Normal Server installation. When 
you install ServerProtect for the first time, you immediately have three default tasks: 
Scan, Statistics, and Deploy. You can edit default tasks, however, you cannot modify the 
task name or the task owner.

Creating Tasks
New tasks let you set up routine maintenance and configuration procedures.
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To create a task:

1. Select the Information Server, domain, or Normal Server on the domain browser 
tree.

2. Do one of the following:

• Click Do > Create Task on the main menu.

• Click Task > New Task on the side bar.

3. Click Create. The Create New Task window appears.

FIGURE 3-48.   Create New Tasks window 

4. Select the functions you want to include in this task in the Existing tasks list.

5. Click Add #n Task Item to add the selected function to the Selected task list. 
You can continue adding more functions. Alternatively, you can remove a 
previously selected function.

Tip:  You can click the up or down arrow icons next to Selected task(s) to change 
the order in which the functions are performed. The Deploy function should 
always be the last one on the list.

6. Select the Create as a scheduled task check box if you want this task to be run 
according to a specified schedule. You can schedule tasks to run on an hourly basis.

7. Click Create to start the wizard and create a task with the selected functions. Click 
Cancel to close the Create New window without saving your changes.
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Creating a Scheduled Task
Creating a scheduled task is easy to configure and save you time.

To create a scheduled task:

1. Follow steps 1 through 6 in the Creating Tasks on page 3-28 section. Make sure you 
select the Create as a scheduled task check box under Scheduled task (see 
Figure 3-48). The Task Wizard window appears.

2. Click Next. The Schedule Settings window appears.

FIGURE 3-49.   Schedule Settings window 

3. Under Scheduled time in the Frequency list, click a download frequency. You can 
select Monthly, Weekly, Daily, or Hourly. If you selected Weekly, click a day in 
the Day of Week list. Alternatively, if you selected Monthly, click a day in the Day 
of month list.
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4. In the Time box, type or select the time when you want to update the components, 
and then click AM or PM.

5. Click Next to proceed with the task wizard configuration.

Specifying a Target for Scan Now
Scan tasks must be run on specific drives. When defining the target drive, you are 
initially given the option to scan all local drives or specific drives and/or directories. The 
latter option also allows you to scan another drive on the network. 

FIGURE 3-50.   Add Drives and/or Directories window 

Creating a Default Task
You can define a default task in the last screen of the task wizard, the Task Information 
window, where you define the name and owner of the task. Default tasks affect all 
Normal Servers managed by an Information Server which means if you add a Normal 
Server, it will inherit existing default tasks.
3-31



Trend Micro™ ServerProtect™ 5.8 Patch 3 Getting Started Guide 
FIGURE 3-51.   Task Information window 

Opening the Existing Task List
The Existing Task list displays information about the tasks that have been created. You 
can use the Existing Task list to perform, modify, delete, or view the task definition.

To open the existing task list, do one of the following:

• Click Task > Existing Task on the side bar.

• Click Do > Existing Task on the main menu.

The Existing Task list is displayed in a table format. The following figure displays the 
different fields. Note that you can sort the list by clicking on the heading of each field.
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FIGURE 3-52.   Viewing Existing Tasks table 

Note: If the servers to which a task is applied are located in different time zones, the 
time/date displayed in the Last Perform Time and Next Schedule fields will reflect 
the local time for each server.

Running an Existing Task
The Existing Task list displays information about all the tasks that have been defined. 
You can use the Existing Task list to perform a task. 

To run an existing task:

1. Do one of the following:

• Click Task > Existing Task on the side bar.

• Click Do > Existing Task on the main menu.

The Existing Task list displays all of the tasks that are currently defined within 
ServerProtect.
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2. Select the task that you want to run, and click Perform Now.

Modifying an Existing Task
Modifying existing tasks saves you valuable configuration time. This way, you do not 
need to spend time configuring new tasks.

To modify an existing task:

1. Do one of the following:

• Click Task > Existing Task on the side bar.

• Click Do > Existing Task on the main menu.

The Existing Task list appears.

2. Click the task in the Existing Task list that you want to modify.

3. Click Modify. The Modify Task window appears.

FIGURE 3-53.   Modify Task window 

4. Do one of the following:

• Select the Modify target server(s) check box to change the servers, on which 
the task is configured to run.

• Select the Modify task definition check box to change the procedures that 
were used to define the task.

5. Click OK.

To modify a target server for an existing task:

1. In the Select Servers to Apply Tasks window select and add the server on which 
you want to run the task.

2. Click Add. 
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FIGURE 3-54.   Select Servers to Apply Tasks window 

3. Click Apply. To close the window without saving your changes, click Cancel. 

To modify a task definition for an existing task:

1. Select each function you want to include in this task in the Existing Tasks list.

FIGURE 3-55.   Modify Tasks window 

2. Click Add #n Task Item to add the function you selected to the Selected task list.

If you want this task to be scheduled to run, make sure that you select the Create 
as a scheduled task check box.
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Tip:  You can click the up or down arrow icons next to Selected task(s) to change 
the order in which the functions are performed. The Deploy function should 
always be the last one on the list.

3. Click Modify to start the wizard that will help you create a task with the functions 
that you have chosen. Click Cancel to close the Create New Task window 
without saving your changes.

Viewing an Existing Task
The attributes of any existing task can be viewed from the Existing Task window. This 
enables you to know exactly what the task will do before executing it.

To view an existing task:

1. Do one of the following:

• Click Do > Existing Task on the main menu.

• Click Task > Existing Task on the side bar.

2. Select the task in the Existing Task list that you want to view.

3. Click View at the bottom of the configuration area. Alternatively, you can 
double-click the task’s record entry in the Existing Task table. The View Task 
Information window appears.
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FIGURE 3-56.   View Task window 

This screen contains three tabbed sections labeled Apply Task to Server, Task 
Contents, and Task Status.

• Apply Task to Server: The Task name and Task owner are displayed on the 
left side of the tab. The Target server displays all the servers on your network 
that the task will run on.

• Task Contents: All of the functions that make up the task are displayed. Click 
a function in the Task sequence list and the function definition will appear in 
the task definition table on the right.

• Task Status: The Target Server displays all of the servers on your network on 
which the task will run. The Current Status, Last Perform Time, and Next 
Schedule fields display the status of the task and the last time it was run.

4. Click OK to close the View Task Information window.

Removing an Existing Task
The Existing Task list displays information about all tasks that have been defined. You 
can use the Existing Task list to delete a task definition.
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To remove an existing task:

1. Do one of the following:

• Click Do > Existing Task on the main menu.

• Click Task > Existing Task on the side bar.

2. In the Existing Task list, select the task you want to remove.

3. Click Remove.

Configuring Notification Messages
Antivirus software is quite useful if it alerts a user or an administrator when a virus is 
detected. ServerProtect enables you to configure both notifications and to whom they 
will be sent. 

ServerProtect notifications comprise of standard and outbreak alerts. Alerts can be 
delivered in various ways. See Setting Alert Methods on page 3-42 for all available delivery 
options.

Standard Alerts
A standard alert is generated whenever a selected event is detected on the designated 
server. You can append additional text to a notification message. 

Notification Events
You can configure ServerProtect to notify you when the following events occur.

• Virus infection: Detection of an infected file on the server

• Spyware/Grayware Detected: Detection of a Spyware-infected file on the server

• Attempt to change write-protected file: Any attempt to change the 
write-protected settings

• Real-time configuration change: Changes to the configuration settings of 
Real-time Scan

• Service load/unload: To stop/start the ServerProtect

• Virus pattern out-of-date: Expiration of the virus pattern file

• Spyware pattern out-of-date: Expiration of the Spyware pattern file
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To configure a standard alert:

1. Select the Information Server domain, or a Normal Server on the domain browser 
tree.

2. Do one of the following:

• Click Configure > Notifications > Standard Alert on the main menu.

• Click Set Notification > Standard Alert on the side bar.

The Standard Alert screen appears.

FIGURE 3-57.   ServerProtect Standard Alert Configuration window 

3. Select the event type check box(es).

4. Click Configure Message for each selected event. The Configure Alert Message 
window appears.

5. Type your desired settings, and then click OK to close the window.

6. Click Set Alert Method to select the way that you want to be notified. Refer to 
Setting Alert Methods on page 3-42 for additional information.

Note: Neither Spyware/Grayware detected nor Spyware pattern out-of-date is supported 
for NetWare systems.
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Note: To find out more on configuring alert messages, refer to the related topic in the online 
help.

Outbreak Alerts
Virus outbreaks have a high potential for damage on a corporate network. Whenever the 
number of virus events exceeds the threshold, an outbreak alert is triggered to notify the 
system administrator. 

This ensures that system administrators or other individuals who need to know about 
the virus outbreak are notified and can then take action against them. A customized 
message will be used to alert of an outbreak.

To configure an outbreak alert:

1. Select the Information Server domain, or a Normal Server on the domain browser 
tree. 

2. Do one of the following:

• Click Set Notification > Outbreak Alert on the side bar.

• Click Configure > Notifications > Outbreak Alert on the main menu.

The Outbreak Alert screen appears.
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FIGURE 3-58.   ServerProtect Outbreak Alert Events Configuration 
Window 

3. Define the outbreak threshold. Specify the number of viruses to be exceeded, and 
the period of consideration, in hours, in the boxes provided.

4. Select the notification methods that the alert uses.

5. Click Configure to access the notification settings for the selected methods. For 
additional information about each modification method, refer to Setting Alert 
Methods on page 3-42.

6. Under Alert Message, click Configure Message to modify the message that will 
be displayed when there is a virus outbreak.

7. Click Apply to save your settings.
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Setting Alert Methods
When a virus outbreak occurs, ServerProtect can notify system administrators, and 
other people you designate using the following methods:

• Message box: A standard Windows pop-up message box is displayed on the 
administrator’s computer.

• Printer: A document is sent to a local or network printer.

• Pager: A message is sent to a pager. This feature requires a modem to be connected 
to the server that is hosting Trend Micro ServerProtect.

• Internet Mail: An email message is sent on detection of viruses.

• SNMP Trap: An alert message is sent to network administrators by SNMP. This 
integrates with other SNMP-compatible management tools that may be deployed 
within your company.

• Windows Event Log: The detection of the virus is written to the Windows event 
log.

You can configure one or several notification methods. Instructions to configure email 
notifications are provided in this document. For other forms of notification, refer to the 
online help.

To configure an alert to be sent by Internet email:

1. Click either the Information Server domain, or a Normal Server on the domain 
browser tree.

2. Do one of the following:

To configure an outbreak alert:

• Click Set Notification > Outbreak Alert on the side bar.

• Click Configure > Notifications and then Outbreak Alert on the main 
menu.

To configure a standard alert:

• Click Configure > Notifications > Standard Alert on the main menu then 
click Set Alert Method.

• Click Set Notification > Standard Alert on the side bar and then click Set 
Alert Method. 

3. Select the Internet mail check box, and then click Configure. The Configure 
Internet Mail window appears.
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FIGURE 3-59.   Configure Internet Email Alerts window 

4. Do the following:

a. Type the name of the mail server in the Mail Server text box.

b. Type the subject of the message in the Subject field text box.

c. Type the name of the sender in the From field text box.

5. Type each recipient of this email message in the To user(s) text box and then click 
Add. You can remove a recipient by selecting the user, and then clicking Remove.

6. Click Save & Test to ensure that the configuration settings are working. If 
successful, the users that you specified receive a test email message.

7. Click OK to save your configuration changes and return to the Set Alert Method 
window.

Note: To find out more about configuring alert messages, refer to the related topic in the 
online help.
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Scanning Viruses
ServerProtect provides three scan modes for detecting viruses: Real-time Scan, Scan 
Now (Manual scan), and Scheduled scan. 

Real-time Scan checks all incoming and outgoing files on the server for signs of 
infection. Scan Now scans on-demand, allowing you to check a server for virus 
exposure immediately. Scheduled scan checks for infected files on selected ServerProtect 
servers at predetermined times.

There are five actions for dealing with infected files: Bypass (Ignore), Delete, Rename, 
Quarantine (Move), and Clean. 

You can do the following:

• Choose the type of files to scan.

• Prevent users from modifying or deleting selected directories/files using the Deny 
Write list. For more information about configuring the Deny write list, see the 
related topic in the online help.

Note: The results of each scan are available in the Scan Result logs. You can take action on 
the infected files directly from the Scan Result window. This provides a convenient 
way to take appropriate actions during a virus infection event. For more information, 
refer to the Viewing Scan Result Information topic in the online help.

Defining Actions Against Viruses
ServerProtect lets you configure the kind of action(s) to take against infected files that 
are found on your network during a Real-time Scan or Scan Now.
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FIGURE 3-60.   Set Virus Action window 

To configure virus actions for a virus type:

1. Click Set Action from the Scan Now or Real-time Scan configuration area. The 
Set Virus Action window appears.

Note: Spyware doesn't support clean action. If the action of virus is clean/delete, for 
spyware virus it will only do delete operation.

2. Under Boot Viruses in the Action list, click the virus action you want 
ServerProtect to take when it finds a boot virus. You can select Auto Clean or 
Bypass.
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3. Under File Viruses, do one of the following: 

• Click Use ActiveAction to set Trend Micro recommended virus actions. 
Beware that the action can be taken to handle spyware infection is limited to 
Bypass, and that the action Clean is not supported to handle spywere 
infection. Applying Clean action to a spyware infected file results the deletion 
of the file.

Note:  When using ActiveAction, spyware action will be bypass/bypass.

• Click Customize scan actions, to select the appropriate action to take against 
the file and macro viruses in the Action and Action if cleaning fails lists. See 
When ServerProtect Finds a Virus (Virus Actions) on page 1-13. For more 
information about ActiveAction, see IntelliScan on page 1-20.

Note: If you selected a Clean action, we recommend that you select the Backup 
infected file before cleaning check box. The virus cleaning process can, on 
rare occasions, damage files and make them unusable.

You should exclude both the backup and quarantine directories from scanning. 
Refer to the Directory Exclusion List topic in the online help for more information. 
The selected scan type is displayed under Scan type to be applied.

4. Click Apply to start using these settings. 

Scanning Profiles
Real-time Scan and Scan Now configurations can be saved as scanning profiles that can 
then be used to create or modify tasks. Alternatively, you can delete profiles if they are 
no longer needed. Scanning profiles can be applied when configuring Scan Now and 
Real-time Scan tasks. For more information, see Choosing a scan profile in the online help.

For scheduled scans, that is, scheduled scan tasks, you can either choose an existing 
scanning profile or create your own. See Modifying an Existing Task on page 3-34.
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To save a scanning profile:

1. Configure a Real-time Scan or Scan Now. See Configuring Real-Time Scan on page 3-48 
and Configuring Scan Now on page 3-51.

2. Click Save As/ Delete Profile. The Save/Delete Profile window appears.

FIGURE 3-61.   Save/Delete Profile window 

3. Type a profile name in the Profile name text box.

4. Click Save to save the new profile. Alternatively, click Close to close the window 
without saving it.

To delete a scanning profile:

1. Do one of the following:

• Click Scan Now > Scan Now on the side bar.

• Click Do > Scan Now on the main menu.

• Click Set Scan option > Real-time Scan on the side bar.

2. Click Save As/ Delete Profile. The Save/Delete Profile window appears.

3. Click the profile you want to delete in the Existing Profiles list.

4. Click Delete to delete the profile. Alternatively, click Close to close the window 
without deleting it.
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Using Real-Time Scan
Real-time Scan constantly scans all files that are accessed and provides powerful virus 
protection that runs in the background. All incoming/outgoing files are monitored, thus 
infected files are prevented from being copied to or from a server.

Configuring Real-Time Scan
The following scan options are specific to Real-time Scan:

• Scan floppy at startup: Your floppy disk drive is scanned for boot viruses when 
you turn your computer on. Any diskette inside your floppy disk drive is also 
scanned. This prevents you from booting your computer with an infected diskette.

• Scan floppy at shutdown: Your computer’s floppy disk drive is checked for boot 
viruses when the computer is shut down and any diskette inside it is also scanned. 

• Scan floppy boot area: This option scans the floppy boot area of your computer. 
This feature protects against Master Boot Record viruses.

• MacroTrap: ServerProtect includes patented MacroTrap™ technology to guard 
against macro viruses in Microsoft™ Office files and templates.

• Scan OLE layers: This option scans embedded files. OLE layer scan offers five 
layers of protection. See OLE Layer Scan on page 1-20 for more information.

• Scan mapped network drive: This option scans any mapped network drive. You 
should have an existing network mapped drive for this option to work.

To configure Real-time Scan:

1. Select the Information Server, domain, or a Normal Server on the domain browser 
tree.

2. Do one of the following:

• Click Set Scan Option > Real-time Scan on the side bar.

• Click Configure > Scan Options > Real time Scan on the main menu.
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FIGURE 3-62.   Real-time Scanning Configuration Window 

3. Select the Enable real-time scan check box.

4. Set the Enable Damage Cleanup Services check box so that the Virus Cleanup 
engine scans for and removes Trojans and Trojan processes. It supports 32-bit and 
64-bit platforms. Clear the check box to disable the service.

5. Under Scan direction choose one of the following:

• Incoming: Scans files copied to the server

• Outgoing: Scans files being copied from the server

• Incoming and Outgoing: Scans all incoming and outgoing files on the server
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6. Under Scan file type, choose one of the following:

• All files: Scans all file types

• IntelliScan: Scans files using true file type identification 

See IntelliScan on page 1-20.

• Selected files: Scans only specified files 

If you choose Selected files, click Extension List to define the file types that 
you want to scan. Refer to Selecting File Types to Scan on page 3-57.

7. Under Scan options, select one or more from the following check boxes:

• Scan floppy at start up

• Scan floppy at shutdown

• Scan OLE layers

• Scan floppy boot area

• MacroTrap

• Scan mapped network drive

See Configuring Real-Time Scan on page 3-48 for additional information on each scan 
option. 

8. Select the Scan compressed files check box to scan compressed files and then 
move the Scan level slider to set the number of compressed layers that you want to 
scan. For information on advanced settings, refer to the Compressed file scan topic in 
the online help.

Note: If you choose to scan selected file types in step 5, make sure you select the 
extensions of compressed files in the extension list. 

9. Click Set Action to configure how ServerProtect acts on infected files. See Defining 
Actions Against Viruses on page 3-44.

10. In case of NetWare Normal Server system, the Real-time Scan configuration setting 
pane in Fig 3-31 has a push button UI element to provide an option for the 
NetWare system.
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FIGURE 3-63.   The Real Time Scan Configuration option for NetWare

Click on NetWare Options... button. The Mac File Scanning Settings dialog box 
appears.

FIGURE 3-64.   The Mac File Scanning Settings Screen

Select the desired file scanning setting and click OK to continue.

11. Click Apply to save your changes or click Save As Profile to recall your 
configuration settings at a later time.

Using Scan Now (Manual Scan)
Scan Now performs a scan on demand. Use Scan Now if you suspect a server has been 
infected.

Configuring Scan Now
You can configure the following for Scan Now:

• Scan target

• Scan file type
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• Scan options

• Compressed file scanning

• Scan priority

• Scan action

To configure Scan Now:

1. Click the Information Server, domain, or a Normal Server on the domain browser 
tree.

2. Do one of the following to bring about the configuration pane for Scan Now 
operation, as shown in Figure 3-31:

• Click Scan Now > Scan Now on the side bar.

• Click Do > Scan Now on the main menu.
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FIGURE 3-65.   Scan Now Configuration window 

3. Set Enable Damage Cleanup Service check box to enable the service. Clear it to 
disable the service.

4. Under Scan target, choose one of the following:

• All local drives: Scans all drives in a server

• Selected drives/directories: Scans specific drives or directories on a server

Click Browse. The Add Drives and/or Directories window appears. Select 
the check box(es) for the drives or directories you want to scan, then click OK 
to close the window.
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FIGURE 3-66.   Add Drives and/or Directories window 

5. Under Scan file type, choose one of the following:

• All files: Scans all files

• Use IntelliScan: Scans files using true file type identification

See IntelliScan on page 1-20.

• Selected files: Scans only specified files

Click Extension List to define the file types that you want to scan. Refer to 
Selecting File Types to Scan on page 3-57.

6. Under Scan options, select Scan OLE layers. Move the Scan OLE layers slider 
to set the number of OLE layers. ServerProtect can scan up to five layers.

7. Under Compressed file scanning, select the Scan compressed files check box. 
Move the Scan level slider to set the number of compressed layers that you want to 
scan. For information on advanced settings, refer to the Compressed file scan topic in 
the online help.

Note: If you choose to scan selected file types in step 4, make sure you include the 
extensions of compressed files in the extension list.
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8. Under Scan priority, click Low, Middle, or High. A high scan priority consumes 
more CPU resources, but can complete scan jobs faster.

9. Click Set Action to configure how ServerProtect acts on infected files. See Defining 
Actions Against Viruses on page 3-44.

10. In case of a NetWare Normal Server, the Scan Now Configuration pane has a push 
button UI element to provide an option for the NetWare system.

FIGURE 3-67.   The Scan-Now Configuration option for NetWare 

Click on NetWare Options... button. The Mac File Scanning Settings dialog box 
appears.

FIGURE 3-68.   The Mac File Scanning Settings Screen

Select the desired file scanning setting and click OK to continue.

11. Click Apply to save the changes or click Save As Profile to recall the configuration 
settings at a later time.
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Running the Scan Now Tool on Windows Normal Servers
Use the Scan Now tool to scan servers of Microsoft Windows Server family without 
accessing the Management Console. Scan Now performs the scan according to the Scan 
Now configurations you have set in the Management Console (for example, Scan target, 
Scan file type).

To run the Scan Now tool:

1. Click Start > Programs > Accessories > Windows Explorer on the Normal 
Server. The Windows Explorer window appears.

2. Click the folder where you installed ServerProtect. The default location for a 32-bit 
operating system is:

C:\Program Files\Trend\SProtect

The default location for a 64-bit operating system is:

C:\Program Files\Trend\SProtect\x64

3. Double-click ScanNow.EXE. A Scan Now is performed.

To stop Scan Now:

1. Click Start > Run on the Normal Server. The Run window appears.

2. Click Browse and locate the ScanNow.EXE file.

The default location for a 32-bit operating system is:

C:\Program Files\Trend\SProtect

The default location for a 64-bit operating system is: 

C:\Program Files\Trend\SProtect\x64

3. Run the tool with the "stop" switch as shown below:

For a 32-bit operating system: 

C:\Program Files\Trend\SProtect\ScanNow.exe /STOP

For a 64-bit operating system: 

C:\Program Files\Trend\SProtect\x64\ScanNow.exe /STOP

4. Click OK. Scan Now stops.
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Note: You must include a space between the file name and the Stop switch.

Scheduled Scanning
A scheduled scan scans files at the time and frequency configured. Use scheduled scans 
to automate routine scans on your Normal Servers. You can create a scheduled Scan 
Now or Real-time Scan by using a scheduled task.

Configuring a Scheduled Scan
You can configure a scheduled Scan Now or Real-time Scan by using a scheduled task. 
Refer to Creating Tasks on page 3-28 for more information.

Note: When a ServerProtect server is installed, ServerProtect automatically applies a Scan 
task to the server. The default Scan task is set to scan all your local directories every 
Friday. 

If the existing task does not suit your needs, you can either edit the default task, or create 
a new one. The ServerProtect Task Wizard guides you through the process of creating 
new tasks.

Selecting File Types to Scan
While configuring a Real-time Scan, Scan Now, or scheduled scan (task scan), 
ServerProtect lets you choose what kinds of files to scan by choosing the file extensions. 
Since only certain kinds of files can contain viruses, you can benefit from this function 
by only scanning those file types that are more likely to be infected.
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To add a file extension for scanning:

1. In the Real-time Scan or Scan Now configuration area, under Scan file type, click 
Selected files, and then click Extension List to define the file types you want to 
scan. The Select File for scanning window then appears.

FIGURE 3-69.   Select Files for Scanning window 

2. Do one of the following:

• Click Add. The Add Program File Extension window appears.

FIGURE 3-70.   Add Program File Extension window 

Type the file extension that you want to add in the text box, and then click OK 
to add the extension to your list. Alternatively, click Cancel to close the 
window without saving your changes. Finally, click OK to close the Select files 
for Scanning window.

• Click Default to add all the default file extensions and then click OK to close 
the Select files for Scanning window. Any customized extensions will be lost.

The default setting provides sufficient protection for most environments. The 
following are the default file extensions:
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• Select the file extension you want to delete, and then click Delete.

Registering With Trend Micro Control Manager

Note: This feature is supported in ServerProtect 5.8 Patch 3 or later releases.

Trend Micro Control Manager is a software management solution that gives an 
administrator the ability to control antivirus and content security programs from a 
central location -- regardless of the program’s physical location or platform. This 
application simplifies the administration of a corporate virus and content security policy. 
To enable ServerProtect integration with Control Manager, you must register the 
product with Control Manager.

For more information about Control Manager, refer to Chapter 5  on page 5-1.

To register ServerProtect with Control Manager:

1. Click Start > ServerProtect Management Console.

2. Do one of the following 

• Click CM Agent Setting on the side bar.

• Click Do > Control Manager (CM) Agent Setting on the main menu.

The CM Agent Setting screen appears.

.ARJ

.CLASS

.DOT

.HLP

.JS

.MPT

.OVL

.PPT

.SHS

.VSD

.XLT

.BIN

.COM

.DRV
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.MSG
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.RAR

.SYS
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.Z

.CAB

.DLL

.EXE
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.MDB
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.POT

.RTF

.TAR
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.ZIP
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.DOC

.GZ

.HTML

.MPP

.OFT

.PPS

.SCR

.VBS

.XLS
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FIGURE 3-71.   CM Agent Setting screen

3. Make sure that the server Registration Status is Not Registered with Control 
Manager. If the status is Control Manager agent not installed, the MCP Control 
Manager agent is not installed on ServerProtect Information Server. To install MCP 
Control Manager agent, refer to Installing MCP Control Manager Agent on page 5-7.

4. Under Connection Settings section on the right pane, configure the following 
fields:

• Group folder name: Type a descriptive name that identifies ServerProtect in 
the Control Manager product tree. The maximum length of Group folder name 
is 19.
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• Entity display name: Type the name of the ServerProtect Information Server. 
Choose this name carefully because this is the name that will display on the 
Control Manager server Product Directory to identify the ServerProtect 
Information server. A unique and meaningful name will help you to quickly 
identify the ServerProtect server in the Product Directory of Control Manager. 
The maximum length of Entity display name is 64.

Note: The Server name or IP address field automatically fills the host name or the IP 
address of the computer on which you have installed ServerProtect.

5. Under Control Manager (CM) Server Settings section, specify the following:

• CM server name or IP address: Type the Control Manager (CM) server name 
or IP address in this field.

• CM server port: Type the Control Manager (CM) server port number that the 
MCP agent uses to communicate with Control Manager.

Select Connect using HTTPS, if you have Control Manager security set to 
medium (HTTPS and HTTP communication is allowed between Control 
Manager and the MCP agent of managed products) or high (Only HTTPS 
communication is allowed between Control Manager and the MCP agent of any 
managed products).

• User name and Password: If your network requires authentication, type the 
authentication information for your Internet Information Services (IIS) server.

Note: If you use IIS server authentication, you cannot set ServerProtect to update 
components from Control Manager. You must specify the URL of an update 
server (either the official Trend Micro update server or the one you set up) as the 
download source in the Scheduled Update or Manual Update screen.

6. If you use a proxy server to access the Trend Micro Control Manager server, select 
Use a proxy server for communication with Control Manger server under 
Proxy Settings section, and then configure the following:

• Proxy Protocol: Select a proxy protocol.

• Proxy server name or IP address: Type the proxy server name or its IP 
address.

• Proxy server port: type the proxy server’s port number.
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• User name and Password fields: If the proxy server requires authentication, 
type the user name and password for the proxy server.

Tip:  Before you click Register button, Trend Micro strongly suggest that check 
whether ServerProtect can connect to the Control Manager server based on the 
settings you specified by clicking the Test Connection button. 

7. Click Test Connection to verify if ServerProtect can connect to the Control Manager 
server using the information you have provided. If ServerProtect is unable to connect to 
the Control Manager server, verify the settings that you have provided. Also, check the 
connection between the ServerProtect computer and the Cotrol Manager server.

8. Click Register to save the settings and register the ServerProtect computer to 
Control Manager.

Verifying ServerProtect status in Control Manager
To check the ServerProtect status on the Control Manager management 
console:

1. In a Web browser, navigate to the following URL:

https://<Control Manager server name>/Webapp/login.aspx

Where <Control Manager server name> is the IP address or host name of the 
Control Manager server.

2. On the menu bar, click Products.

3. From the tree, expand the group folder name that you provided while registering 
ServerProtect with Control Manager.

4. Verify if the server you had registered, appears in the list.

Unregistering from Control Manager
To unregister ServerProtect computer from Trend Micro Control Manager:

1. Click Start > ServerProtect Management Console.

2. Do one of the following 

• Click CM Agent Setting on the side bar.

• Click Do > Control Manager (CM) Agent Setting on the main menu.
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The CM Agent Setting screen appears.

3. Click Unregister.
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Chapter 4

Upgrade Existing ServerProtect

ServerProtect supports the product upgrading and migration from the previous versions 
of the product. The configuration settings of older versions can be migrate and stay 
effective in the new version of application

The version 5.8 installation program can detect the existence of ServerProtect 
components, including the Normal Server, the Information Server and Management 
Console. The upgrading and migration feature is an integral part of the ServerProtect 
installation program. This chapter introduces the key concepts and presents to the user 
how to use the feature.

The topics included in this chapter are:

• Overview of ServerProtect Upgrade Feature on page 4-2

• Use the Installation Package to Upgrade ServerProtect Locally on page 4-3

• Use the Installation Package to Upgrade ServerProtect Remotely on page 4-5

• Perform a Silent Mode Installation to Upgrade the Normal Servers on page 4-6

• Use the Deploy Program to Upgrade the Normal Servers on page 4-8
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Overview of ServerProtect Upgrade Feature
Many users of the ServerProtect have a previous version of product already installed on 
their network server system, such as ServerProtect 5.58 or 5.7. The upgrade feature 
integrated in ServerProtect 5.8 offers a number of upgrade options for the users to 
choose, whichever the most effective will be to serve the purpose. This overview 
explains each of the options and introduces the related key concepts.

1. Because ServerProtect 5.8 Information Server refuses adding and moving Normal 
Server request to old normal Servers (version of 5.58 and 5.7), make sure that you 
move all the old Normal Servers need upgrade into the Information Server to be 
upgraded.

WARNING!  Remote upgrades run from a 32-bit machine will be unsucessful if 
the Normal Server is a 64-bit machine. To resolve, perform the 
upgrade by doing a local installation, silent installation, or deploy 
program to upgrade ServerProtect 5.7 normal server on a 64bit 
machine.

Note: You also can’t add old normal server by "Adding a Normal Server" and "Moving 
Normal Server" function.

Note: If you want to use "deploy program" function to upgrade ServerProtect 5.7 
Normal Servers, make sure the ServerProtect 5.7 Normal Server has been 
applied the hotfix or patch that is greater than build 1095 to enable the "program 
updating" function.

2. Launch the ServerProtect installation and make proper selection to install an 
Information Server of the latest version of ServerProtect 5.8. To upgrade an 
existing Information Server, simply select the same target server during the course 
of installation.See Use the Installation Package to Upgrade ServerProtect Locally on page 4-3 
for details.

3. The next move is to install the Management Console component if the latest 
version one is not yet in place. See Use the Installation Package to Upgrade ServerProtect 
Locally on page 4-3 for detailed information.
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4. At this point the Management Console and the Information Server are ready. The 
Normal Server can be upgraded by the following methods: 

• Use the installation package to perform the upgrade locally.

• Use the installation package to perform the upgrade remotely across the 
network.

• Use silent mode installation to perform the upgrade. The silent mode 
installation should be used to upgrade the machine only with Normal Server 
installed. if the silent installer detects that other components is installed, it will 
terminate and does nothing. We recommend that this method be the only one 
to upgrade the Normal Servers. It can prevent upgrading Information Server 
on the remote target machine by accident.

• Use Deploy program feature of ServerProtect 5.8 to perform the upgrade

Note: For the server network system that has 5.7 version of ServerProtect Normal 
Servers installed, please upgrade patch for all spnt 5.7 normal server to enable 
“deploying” program function. Please contact Trend Micro Technical supporter 
for detail information. SPNT 5.58 hasn’t this kind of issue because it already has 
this feature.

The rest of this chapter will focus on presenting comprehensive information. While the 
major attention is to describe how to perform Normal Server upgrading, the upgrade 
details for other components, together with related key concepts, will also be presented 
in aiding the users to achieve an effective and smooth program upgrade.

Use the Installation Package to Upgrade 
ServerProtect Locally

Because the Upgrade feature is an integral part of the ServerProtect installation 
program, no differences exist at all in term of user interface appearances and program 
behaviors. Upgrading the ServerProtect locally is by far the most straight-forward and 
reliable option. It is also the only way to install or upgrade a Management Console 
component.
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To initiate a local upgrade session, use the installation package to launch the installation 
session in the local computer. See Installing ServerProtect on page 2-10 for detailed 
information. The installation program will the user through the whole procedure. At the 
ServerProtect Select Component window as shown in the following:

FIGURE 4-72.   The ServerProtect Select Component Window

Note: Always keep in mind that all those components known to be existing in the system 
must be selected to achieve a successful upgrade.

Set the check box corresponding to those options need to be upgraded and click 
Browse... to bring up ServerProtect Installation Path Selection window. See 
ServerProtect Install Path Selection screen on page 2-23. Navigate to the target folder which 
needs to be upgraded on the local computer. The installation program will complete the 
upgrade after copying the program files and starting all related services.
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Note: When make the selection to upgrade one ServerProtect component, keep in mind to 
select all the existing components, including those of the latest version already. 
Otherwise the installation program will pop up message box, stating that other 
components must be choose to continue, and bring the user back to the 
ServerProtect Selection Component window and request the user to redo the 
selection

Note: If Trend Micro Control Manager Agent is installed, it should be upgraded after the 
Information Server is installed.

Use the Installation Package to Upgrade 
ServerProtect Remotely

The way to remotely upgrade the ServerProtect is not very different to that of doing it 
locally. After launching the ServerProtect installation program, accepting the agreement 
terms and submitting the correct serial number, The ServerProtect Select Component 
window will be brought up. When choosing a Normal Servers as the upgrade candidate 
using Browser... button to locate the target server, instead of exploring in the local 
computer, the user can navigate to the connected server network system, locate the 
Normal Server or Information Server need to be upgraded and perform the upgrade 
operation just as doing it locally. See Installing ServerProtect on page 2-15 for detailed 
information.

WARNING! Remote upgrades run from a 32-bit machine will be unsucessful if the 
Normal Server is a 64-bit machine. To resolve, perform the upgrade by 
doing a local installation, silent installation, or deploy program to 
upgrade ServerProtect 5.7 normal server on a 64bit machine.

Note: ServerProtect does not support installing or upgrading the Management Console 
component remotely.
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Perform a Silent Mode Installation to Upgrade 
the Normal Servers

It is well known that, under Microsoft Windows environment, executing program by 
running it in DOS command line window has certain advantages. The Windows shell is 
capable of interpreting commands which compose a script file. One can compose such a 
file to automate certain tasks. In ServerProtect 5.8, capable of launching the installation 
program in silent mode let the users to enjoy such advantages.

Note: The silent install should be used to upgrade the server only with normal server exists. 
When silent installer detects the other components, it will quit and do nothing.

To install ServerProtect in silent mode:

1. Install an Information Server.

2. Locate the SMS folder in the default installation path, and share it. Make sure the 
target servers you want to install as Normal Servers can access the folder. If you 
want to perform more than one silent installation, map the SMS folder on the target 
servers.

3. At the target server, open a command prompt, go to the SMS folder or drive that is 
mapped to the folder, and then enter the following command: 

<drive>:\setup -SMS -s -m"SPNT5"

Example:

a. At the target server, map the SMS folder to drive "M".

b. Open a command prompt.

c. Go to drive M: by typing "M:".

d. Type the following:

M:\setup -SMS -s -m"SPNT5"

e. Press Enter.

Silent install will proceed and the target server will be registered with the Information 
Server.
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For a silent installation, Normal Servers are installed in the "SMS" domain. There is no 
way to change the domain name during the silent installation. You can, however, rename 
the SMS domain after all the Normal Servers have been installed.

You can also specify a path to which ServerProtect is installed. For example, to install 
ServerProtect to the path "D:\Utility\AntiVirus\SProtect" do the following:

1. Locate the Setup.ini file in the source folder.

2. Add the following lines:

[CommonSection]

ServerTargetUNCPath=D$\Utility\AntiVirus\SProtect

Where:

ServerTargetUNCPath: Sets the location where the Normal Server is installed. 

To license the installed Normal Server, add the following lines to the Setup.ini file in 
the source folder.

[CommonSection]

ServerTargetSN=XXXX-XXXX-XXXX-XXXX-XXXX

Where:

XXXX-XXXX-XXXX-XXXX-XXXX: Represents the legal serial number.

You may not be able to register a Normal Server under the "SMS" domain due to the 
use of a domain controller on the Information Server. To resolve this issue, configure an 
IP address before using silent install.

To configure an IP address, do the following:

1. Go to the Setup.ini file in the SMS folder.

2. Replace the host name with its IP address next to AgentName then save the file.

Note: During the course of perform upgrade in silent mode, caution should be excised when 
sharing with others the SMS folder so that all those target servers needs to be 
upgraded are included. See Installing ServerProtect in Silent Mode on page 2-43 for 
detailed information to use this powerful tool.
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Use the Deploy Program to Upgrade the Normal 
Servers

Performing upgrade using the Deploy feature is the most convenient way to upgrade the 
obsolete Normal Servers in a server network system. The new Normal Server program 
code, with the rest of antivirus elements such as spyware and virus pattern files, scan 
engine and DCE services, will be downloaded to one of the Information Server and 
deployed into the system. The only action for a server network administrator to take is 
choosing in the program’s UI element to do so.

Note: If you want to use "deploy program" function to upgrade ServerProtect 5.7 
Normal Servers, make sure the ServerProtect 5.7 Normal Server has been 
applied the hotfix or patch that is greater than build 1095 to enable the "program 
updating" function. Visit Trend Micro’s support Web site for more information.

Note: When deploy program, all Information Server’s and Management Console’s files are 
copied into the Normal Server. This operation will not create Information Server 
service and Management Console application. 

To use ServerProtect 5.8 upgrade:

1. When upgrading ServerProtect 5.7, ensure the Normal Server version 5.7 binary 
build is 1095 or greater.

2. If the Information Server is connected to the Trend Micro Control Manager Server, 
download the following: 

• From the main console, click Update > Update or click Do > Update from 
the main menu.

• Click Configure to open the Download Option screen. 

• Change the Download source to Internet, and change the download URL to: 

http://spnt58-p.activeupdate.trendmicro.com/activeupdate/

• Click OK to apply the settings.

• Click Download Now. 
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• After the download completes, verify that server.ini located in: 
{ServerProtect home directory}\SpntShare\ contains the following 
information:

Note: The ServerProtect Information Server default path is: C:\program 
files\Trend\Sprotect\SpntShare. 

[Info_186_50000_1_5121]

Version=5.8

Update_Path=serverprotect/spnt580/auspnt50.zip, 43914

Min=5.0

Max=6.0

Path=ServerProtect/SPNT58.zip, 36730864

[Info_2_50000_1_1]

Version=5.8

Update_Path=serverprotect/spnt580/auspnt50.zip, 43914

Min=5.0

Max=6.0

Path=ServerProtect/SPNT58.zip, 39824843

3. Do one of the following:

• Click Update > Update on the side bar.

• Click Do > Update from the main menu.

4. Click Deploy Now. A confirmation window appears. Click Yes to proceed with the 
manual update deployment. The Deploy window appears.
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FIGURE 4-73.   The Deploy Window

5. To enable upgrading Normal Server feature by download and deployment, simply 
set the check box corresponding to the item ServerProtect Program. Note that 
this option is not among the three antivirus components selected as default at 
application initialization. Click Deploy to dismiss the Deploy window and conclude 
the upgrade operation. 
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Chapter 5

Managing ServerProtect with Trend 
Micro Control Manager™

Trend Micro Control Manager (TMCM) delivers powerful centralized management of 
antivirus and content security solutions deployed throughout the network. With single 
point-of-contact administration, monitoring, and deployment, corporations can more 
effectively manage their antivirus and content security strategies enterprise-wide.

Because it is Web-based, Control Manager can be accessed from any server that runs 
Microsoft™ Internet Explorer. Unlike the Management Console, The Control Manager 
Web-console allows you to manage several Information Servers at the same time giving 
you greater control and flexibility over your antivirus strategy.

A ServerProtect Information Server can only manage the Normal Servers that are 
registered with it. Control Manager, on the other hand, can control groups of 
Information Servers, and consequently the Normal Servers they manage. Thereby 
simplifying the management of large networks.

The topics included in this chapter are:

• What is Trend Micro Control Manager? on page 5-2

• Understanding Trend Micro Management Communication Protocol on page 5-3

• Installing and Removing Control Manager Agent for ServerProtect on page 5-6

• Control Manager Agent for ServerProtect Features on page 5-8
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What is Trend Micro Control Manager?
Control Manager is a software management solution that gives an administrator the 
ability to control antivirus and content security programs from a central location -- 
regardless of the program’s physical location or platform. This application simplifies the 
administration of a corporate virus and content security policy.

Control Manager provides a comprehensive view of the entire network, identifying how 
Trend Micro products and services, including ServerProtect, can be deployed to create 
effective, targeted antivirus strategies.

Control Manager maintains a connection with the update server, which provides 
knowledge and services developed by TrendLabs™. This process enables administrators 
to stay abreast of the latest virus activity and to be proactive in responding to potential 
threats in their own environment.

During an attack, the Trend Micro Control Manager Web-based console functions as a 
centralized "command post" to monitor the outbreak progress, implement containment 
strategies, deploy newly downloaded pattern files as soon as they become available, and 
manage cleanup activities. The degree of containment affects all kinds of costs from the 
effects of the virus on employee productivity to the amount of time needed for cleanup.

Control Manager is key component of the Trend Micro Enterprise Protection Strategy. 
Trend Micro Enterprise Protection Strategy (TM EPS) delivers a framework for 
coordinated enterprise protection of the virus outbreak life cycle.

The virus outbreak lifestyle is comprised of three primary phases: outbreak prevention, 
pattern file generation and deployment, and damage assessment and cleanup. Designed 
to meet enterprise demands for comprehensive antivirus protection, TM EPS offers a 
flexible architecture composed of scalable, multi-platform services, products, centralized 
management and knowledge. 

TM EPS transforms the traditional point-based approach to antivirus protection into an 
enterprise-wide security strategy through centralized deployment of outbreak 
prevention, detection, protection, and cleanup strategies across the network. 

Control Manager offers you the following benefits:

• Secure communication infrastructure

• Task delegation

• Command tracking
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• Real-time product control

• Centralized installation of agents

• Centralized update control

• Centralized configuration

• Centralized log reporting

Understanding Trend Micro Management 
Communication Protocol

Trend Micro Management Communication Protocol (MCP) is Trend Micro's next 
generation agent for managed products. MCP replaces Trend Micro Management 
Infrastructure (TMI) as the way Control Manager communicates with ServerProtect for 
Microsoft Windows and Netware. MCP has several new features:

• Reduced network loading and package size

• NAT and firewall traversal support

• HTTPS support

• One-way and Two-way communication support

• Single sign-on (SSO) support

• Cluster node support

Reduced Network Loading and Package Size
TMI uses an application protocol based on XML. Even though XML provides a degree 
of extensibility and flexibility in the protocol design, the drawbacks of applying XML as 
the data format standard for the communication protocol consist of the following:

• XML parsing requires more system resources compared to the other data formats 
such as CGI name-value pair and binary structure (the program leaves a large 
footprint on your server or device).

• The agent footprint required to transfer information is much larger in XML 
compared with other data formats.

• Data processing performance is slower due to the larger data footprint.

• Packet transmissions take longer and the transmission rate is less than other data 
formats.
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MCP's data format is devised to resolve the issues mentioned above. MCP's data format 
is a BLOB (binary) stream with each item composed of name ID, type, length and value. 
This BLOB format has the following advantages:

• Smaller data transfer size compared to XML: Each data type requires only a 
limited number of bytes to store the information. These data types are integer, 
unsigned integer, Boolean, and floating point.

• Faster parsing speed: With a fixed binary format, each data item can be easily 
parsed one by one. Compared to XML, the performance is several times faster.

• Improved design flexibility: Design flexibility is also been considered since each 
item is composed of name ID, type, length and value. There will be no strict item 
order and compliment items can be present in the communication protocol only if 
needed.

In addition to applying binary stream format for data transmission, more than one type 
of data can be packed in a connection, with/or without compression. With this type of 
data transfer strategy, network bandwidth can be preserved and improved scalability is 
also created.

NAT and Firewall Traversal Support
With limited addressable IPs on the IPv4 network, NAT (Network Address Translation) 
devices have become widely used to allow more end-point computers to connect to the 
Internet. NAT devices achieve this by forming a private virtual network to the 
computers attached to the NAT device. Each computer that connects to the NAT 
device will have one dedicated private virtual IP address. The NAT device will translate 
this private IP address into a real world IP address before sending a request to the 
Internet. This introduces some problems since each connecting computer uses a virtual 
IP and many network applications are not aware of this behavior. This usually results in 
unexpected program malfunctions and network connectivity issues.

For products that work with TMCM 2.5/3.0 or higher agents, one pre-condition is 
assumed. The server relies on the fact that the agent can be reached by initiating a 
connection from server to the agent. This is a so-called two-way communication 
product, since both sides can initiate network connection with each other. This 
assumption breaks when agent sits behinds a NAT device (or TMCM server sits behind 
a NAT device) since the connection can only route to the NAT device, not the product 
behind the NAT device (or the TMCM server sitting behind a NAT device). One 
common work-around is that a specific mapping relationship is established on the NAT 
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device to direct it to automatically route the in-bound request to the respective agent. 
However, this solution needs user involvement and it does not work well when 
large-scale product deployment is needed.

The MCP deals with this issue by introducing a one-way communication model. With 
one-way communication, only the agent initiates the network connection to the server. 
The server cannot initiate connection to the agent. This one-way communication works 
well for log data transfers. However, the server dispatching of commands occurs under a 
passive mode. That is, the command deployment relies on the agent to poll the server 
for available commands.

HTTPS Support
The MCP integration protocol applies the industry standard communication protocol 
(HTTP/HTTPS). HTTP/HTTPS has several advantages over TMI:

• A large majority of people in IT are familiar with HTTP/HTTPS, which makes it 
easier to identify communication issues and find solutions those issues.

• For most enterprise environments, there is no need to open extra ports in the 
firewall to allow packets to pass

• Existing security mechanisms built for HTTP/HTTPS, such as SSL/TLS and 
HTTP digest authentication, can be used.

Using MCP, Control Manager has three security levels:

• Normal security: Control Manager uses HTTP for communication

• Medium security: Control Manager uses HTTPS for communication if HTTPS is 
supported and HTTP if HTTPS is not supported

• High security: Control Manager uses HTTPS for communication

One-Way and Two-Way Communication Support
MCP supports one-way and two-way communication.

One-Way Communication
NAT traversal has become an increasingly more significant issue in the current 
real-world network environment. In order to address this issue, MCP uses one-way 
communication. One-way communication has the Control Manager agent initiating the 
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connection to and polling of commands from the server. Each request is a CGI-like 
command query or log transmission. In order to reduce the network impact, the 
connection is kept alive and open as much as possible. A subsequent request uses an 
existing open connection. Even if the connection is dropped, all connections involving 
SSL to the same host benefit from session ID cache that drastically reduces 
re-connection time.

Two-Way Communication
Two-way communication is an alternative to one-way communication. It is still based on 
one-way communication, but has an extra channel to receive server notifications. This 
extra channel is also based on HTTP protocol. Two-way communication can improve 
real time dispatching and processing of commands from the server by the Control 
Manager agent. The Control Manager agent side needs a Web server or CGI compatible 
program that can process CGI-like requests to receive notifications from Control 
Manager server.

Single Sign-on (SSO) Support
Through MCP, Control Manager 3.5 now supports single sign-on (SSO) functionality 
for Trend Micro products. This feature allows users to sign in to Control Manager and 
access the resources of other Trend Micro products without having to sign in to those 
products as well. 

Cluster Node Support
Under varying cases administrators may like to group certain product instances as a 
logical unit, or cluster (for example products installed under a cluster environment 
present all installed product instances under one cluster group). However, from the 
Control Manager server's perspective, each product instance that goes through the 
formal registration process is regarded as an independent managed unit and each 
managed unit is no different from another.

Through MCP, Control Manager supports cluster nodes.

Installing and Removing Control Manager 
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Agent for ServerProtect
ServerProtect enables you to communicate with Trend Micro Control Manager using 
the Trend Micro Management Communication Protocol (MCP). The MCP is Trend 
Micro's next generation agent for managed products that replaces Trend Micro 
Management Infrastructure (TMI) as the way Control Manager communicates with 
ServerProtect for Microsoft Windows and Netware. 

If you have not installed TMI before, or need to re-install MCP agent manually, see 
Installing MCP Control Manager Agent on page 5-7.

Installing MCP Control Manager Agent for ServerProtect
ServerProtect 5.8 Patch 3 enables you to upgrde TMI Control Manager agent to MCP 
Control Manager agent using a migration tool. However, if you do not want to keep the 
old information data, you can manually remove TMI Control Manager agent and install 
the MCP Agent manually.

Note: TMI Control Manager agent will automatically upgrade to MCP Control Manager 
agent after applying ServerProtect 5.8 Patch 3.

Installing MCP Control Manager Agent

Note: This procedure only applies to ServerProtect 5.8 Patch 3 or later releases.

To install MCP Control Manager agent:

1. Log on to the Information Server using a Windows Administrator account with 
Domain Administrator privileges.

2. Navigate to the following folder on the server where you have installed 
ServerProtect:

..\Trend\SProtect\SMS\CMAgent

3. Double-click MCP_CMAgent.exe under the CMAgent folder.

The Trend Micro Control Manager Agent for ServerProtect setup screen 
appears.
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4. On the Welcome screen, click Next. 

5. Read the license agreement. You must agree to the license conditions to proceed 
with Setup. Click Next.

6. Follow the installation on-screen instructions to complete the installation.

Removing MCP Control Manager Agent
The Control Manager agent can be easily removed from the Control Panel on 
ServerProtect Information Server computer.

To remove the Trend Micro Control Manager Agent for ServerProtect:

1. On the Information Server computer, click Start > Control Panel > Programs 
and Features.

2. Click Trend Micro Control Manager Agent for ServerProtect, and then click 
Uninstall. A message box appears.

3. Click Yes to remove the Control Manager Agent for ServerProtect.

4. Click Close to finish.

Control Manager Agent for ServerProtect 
Features

Control Manager agent for ServerProtect includes several features to manage 
ServerProtect.

Note: Only some of the ServerProtect Management Console features are available in the 
Control Manager Web-console.

Centralized Configuration
Centralized configuration, using the Product Directory and cascading management 
structure, allows you to coordinate virus-response and content security efforts from a 
single management console. This ensures consistent enforcement of your organization's 
virus and content security policies.
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On-Demand Product Control
The Control Manager provides you with real-time product control. Control Manager 
immediately carries out predetermined virus scan actions and applies configuration 
modifications made on the management console to the managed products. System 
administrators can run manual scans from the management console. This feature is 
indispensable during a virus outbreak.

Centralized Update Control
Centralized updates of spam rules, virus patterns, scan engines, and other antivirus and 
content security components ensure that all products contain the latest malware 
protection. You can view your entire network’s protection status from a single 
management console.

Centralized Monitoring
Centralized monitoring gives you an overview of the antivirus and content security 
product performance using comprehensive logs and reports. The Control Manager 
collects logs from all its managed products; you do not need to check the logs of each 
individual product.

Control Manager tasks are different from ServerProtect tasks. ServerProtect tasks are 
customized, and saved for later use. Control Manager tasks are predefined and executed 
immediately. ServerProtect and Control Manager tasks can run simultaneously without 
interfering with each other.

Use the Control Manager Web-console to perform the following Control Manager tasks:

• Perform a manual scan (Scan Now).

• Enable a Real-time Scan.

• Deploy a virus pattern file/cleanup templates.

This command will deploy virus pattern, Damage Cleanup templates and Spyware 
pattern together.

• Deploy a scan engine file.

This command will deploy virus scan engine, Damage Cleanup Engine and 32bits 
Anti-Rootkit Driver.
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• Deploy program files.

• This command will deploy program files to normal server. If the normal server is 
already version 5.8, this command doesn’t doing anything.

FIGURE 5-74.   Services screen

The Services screen is your primary interface with the Trend Micro Outbreak 
Prevention Service, and is the principal means of implementing outbreak prevention 
policies.
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Chapter 6

Registering and Contacting Technical 
Support

This chapter contains information to help you register and contact technical support.

The topics included in this chapter are:

• Technical Support Information on page 6-1

• Trend Micro Security Information on page 6-2

• Using Knowledge Base on page 6-3

• Sending Trend Micro Your Viruses on page 6-3

• TrendLabs™ on page 6-4

Technical Support Information
A license to Trend Micro antivirus software includes the right to receive pattern file 
updates and technical support from Trend Micro or an authorized reseller, for one (1) 
year. Thereafter, you must renew Maintenance on an annual basis at Trend Micro's 
then-current maintenance fees to have the right to continue receiving these services.

Evaluation copies of all Trend Micro products can be downloaded from the Trend 
Micro Website.
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Refer to the following online resources for technical support:

Email: sales@trendmicro.com

support@support.trendmicro.com

Web Support: http://esupport.trendmicro.com/support/smb

Knowledge Base: http://esupport.trendmicro.com/support/smb/search.do

Virus Information Center: www.trendmicro.com/vinfo

Trend Micro Security Information
Comprehensive security information is available on the Internet at the Security 
Information section of the Trend Micro Website:

www.trendmicro.com/vinfo/

Use Security Information to learn about: 

• Computer virus hoaxes

• A weekly virus alert, listing the viruses that will trigger during the current week

• How to determine if a virus detection is a false alarm

• Trend Micro Virus Encyclopedia, which includes a comprehensive list of names and 
symptoms for known viruses and malicious mobile code

• A basic guide to computer viruses

• Trend Micro virus reading room, with dozens of articles about the latest issues in 
computer viruses, including the threat posed by Java applets and ActiveX controls

• Product details and white papers

You can also access Trend Micro Virus Encyclopedia from the Management Console. 
Click View > View Virus Encyclopedia on the main menu.
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Registering Trend Micro ServerProtect
Trend Micro or an authorized reseller provides technical support, virus pattern 
downloads, and program updates for one (1) year to all registered users, after which you 
must purchase renewal maintenance.

To register ServerProtect visit the following Website:

www.trendmicro.com/support/registration.asp

Using Knowledge Base
Trend Micro provides Knowledge Base, an online database filled with answers to 
technical product questions. Use Knowledge Base, for example, if you are getting an 
error message and want to find out what to do. 

http://esupport.trendmicro.com/support/smb/search.do

New solutions are added daily. However, if you don't find the answer you seek, you can 
submit your question online, where the personnel at TrendLabs™ will provide you with 
an answer or contact you for more information.

Sending Trend Micro Your Viruses
ServerProtect detects infected files by means of pattern-matching (comparing files being 
scanned to the "fingerprints" of known viruses) and heuristics (monitoring the behavior 
of a file for tell-tale virus-like behavior). While these two methods are sufficient for most 
users, you also receive the support of Trend Micro antivirus engineers.

If you find a suspicious file (that is, ServerProtect does not identify it as a virus but you 
find that it exhibits strange behavior), or find a file that causes a "false alarm" (that is, 
you know that the file is not infected but ServerProtect identifies it as a virus), we invite 
you to send it to Trend Micro virus engineers for further analysis.

To submit a file to Trend Micro Virus Doctor:

1. Select a Normal Server on the domain name tree.

2. Click Do > Submit File on the main menu. The Submit File screen appears.

3. Type your name, company, phone and email address in the appropriate text boxes.
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4. Type a brief description of the nature of the problem.

5. Type the name of the SMTP server that you want to use.

6. Click Browse to select the file you want to attach. The Select File window appears.

7. Select the file you want to submit, and then click OK.

8. Click Submit to send the message.

Our team of engineers will "dissect" the file to identify and characterize any virus(es) it 
may contain and return the cleaned file to you usually within 48 hours.

TrendLabs™
TrendLabs 24x7 global antivirus research and support centers form the backbone of 
Trend Micro service infrastructure. A team of more than 250 engineers operates around 
the clock at sites spanning the globe to keep customers informed and protected against 
the latest security threats. TrendLabs includes service centers in Tokyo, Paris, California, 
Taipei, Munich and its ISO 9002-certified headquarters in Metro Manila.
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Appendix A

Converting the ServerProtect Trial 
Version

A 30-day trial version of ServerProtect will be installed if no serial number is entered. 
This version will be fully functional but after 30-days virus scanning will be disabled. 
After this, you should either purchase the product or remove it. 

After purchasing a license, refer to the following topics to update the serial number.

The topics included in this chapter are:

• The Software Evaluation Period Window

• Viewing the Serial Number List

• Updating a Serial Number
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The Software Evaluation Period Window
If you install the trial version of ServerProtect, the Software Evaluation Period 
window appears every time you open the Management Console. The Software 
Evaluation Period window shows which Normal Servers are using the trial version and 
the number of days remaining until they expire.

FIGURE A-1.   Software Evaluation Period window 

Viewing the Serial Number List
Using the Management Console, you can view the serial number of all the ServerProtect 
Normal Servers.
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Converting the ServerProtect Trial Version
To view the serial number list:

1. Click Help > About on the main menu. The About ServerProtect Management 
Console window appears.

FIGURE A-2.   About ServerProtect Management Console window 

2. Click Serial Number. The Serial Number List window appears showing you all 
the ServerProtect Normal Servers on your network, along with their respective 
serial numbers.
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FIGURE A-3.   ServerProtect Serial Number List Window 

3. Click Close to close the Serial Number List window, and then click OK to close 
the About ServerProtect Management Console window.

Updating a Serial Number
After you have purchased a ServerProtect license, you can update the serial number of 
installed ServerProtect software directly from the Management Console without 
reinstalling ServerProtect.

To update a serial number:

1. Select the Normal Server you want to update the serial number for in the domain 
browser tree.

2. Click Do > Update Serial Number on the main menu. The Enter New Serial 
Number window appears.
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Converting the ServerProtect Trial Version
FIGURE A-4.   Enter New Serial Number window 

3. Type the new serial number in the New serial number text boxes.

4. Click OK. Otherwise, click Cancel to close the window.
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