Log Inspection Events

Vulnerability ProtectionDeep Security Manager collects Log Inspection Events from the Vulnerability ProtectionDeep Security Agents at every heartbeat. The data from the logs is used to populate the various reports, graphs, and charts in the Vulnerability ProtectionDeep Security Manager.

Once collected by the Vulnerability ProtectionDeep Security Manager, Event logs are kept for a period of time which can be set in Administration > System Settings > Storage. The default setting is one week.

From the main page you can:

Additionally, right-clicking an Event gives you the option to:

Columns for the Log Inspection Events display:

View Event Properties

Double-clicking an event displays the Properties window for that entry which displays all the information about the event on one page. The Tags tab displays tags that have been attached to this Event. For More information on Event tagging, see Policies > Common Objects > Other > Tags, and Event Tagging in the Reference section.

Filter the List and/or Search for an Event

The Period toolbar lets you filter the list to display only those events that occurred within a specific timeframe.

The Computers toolbar lets you organize the display of event log entries by computer groups or computer Policies.

Use the "Search" or "Advanced Search" options to search, sort, or filter displayed events.

Advanced Search functions (searches are not case sensitive):

Export

Clicking the Export... button exports all event log entries to a CSV file.

Auto-Tagging

Clicking Auto-Tagging... displays a list of existing Log Inspection Auto-Tagging Rules.

You can use Auto-tagging to automatically apply tags for the Log Inspection groups. LI rules have groups associated with them in the rules. For example:

<rule id="18126" level="3">
<if_sid>18101</if_sid>
<id>^20158</id>
<description>Remote access login success</description>
<group>authentication_success,</group>
</rule>

<rule id="18127" level="8">
<if_sid>18104</if_sid>
<id>^646|^647</id>
<description>Computer account changed/deleted</description>
<group>account_changed,</group>
</rule>

Each group name has a "friendly" name string associated with it. In the above example, "authentication_success" would be "Authentication Success", "account_changed" would be "Account Changed". When this checkbox is set, the friendly names are automatically added as a tag for that event. If multiple rules trigger, multiple tags will be attached to the event.